5 Replies Latest reply: Sep 5, 2011 8:32 AM by 885551 RSS

    Error ORA-12154 trying to connect with instant client 11g / LDAP on Ubuntu


      I have successfully installed instant client and sqlplus on my Ubuntu 11.04 workstation. I am able to successfully connect to DB's defined in tnsnames.ora, but when the resolution is (or should be) by LDAP, I get error

      ORA-12154: TNS:could not resolve the connect identifier specified

      Note: while it's fine for testing, it's not a viable option to setup all the DB's defined in the OID in tnsnames.ora - I need to use LDAP.

      My setup is as follows:

      Install folder: /opt/oracle/instantclient_11_2


      I am certain that tnsnames.ora and ldap.ora are valid, as I can connect successfully on another machine with the full client installed using the same files.

      I tried to setup tracing in sqlnet.ora as follows
      TRACE_FILE_CLIENT = sqlnet.trc
      but not trace file gets generated in /tmp - am I doing something wrong ? (Note, I also tried to set DIAG_ADR_ENABLED=OFF as suggested by Laurenz Albe in Instant client don't work trace but that did not help)

      I checked DocID=359206.1 but I don't think that applies as I'm on 11g.

      Hope someone can help. Thanks in advance !