12 Replies Latest reply on Sep 29, 2011 2:53 PM by ostendali

    ssh service in maintenance mode and not restarting!

    ostendali
      Hi everyone!
      could someone pls hlp to figure out with ssh service in maintenance mode?

      Here the details:

      This is a solaris 10 local zone

      SunOS 5.10 Generic_127128-11 i86pc i386 i86pc

      svc:/network/ossh:default (SSH server)
      State: maintenance since Wed Sep 28 12:23:47 2011
      Reason: Restarting too quickly.
      See: http://sun.com/msg/SMF-8000-L5
      See: man -M /usr/local/man -s 8 sshd
      See: /var/svc/log/network-ossh:default.log
      Impact: This service is not running.

      Log files for sshd:
      [ Sep 28 12:23:47 Method "start" exited with status 0 ]
      [ Sep 28 12:23:47 Stopping because all processes in service exited. ]
      [ Sep 28 12:23:47 Executing stop method ("/lib/svc/method/ossh stop") ]
      [ Sep 28 12:23:47 Method "stop" exited with status 0 ]
      [ Sep 28 12:23:47 Restarting too quickly, changing state to maintenance ]
      [ Sep 28 12:33:02 Rereading configuration. ]

      And system log messages:
      Sep 28 12:23:47 svc.startd[911]: [ID 748625 daemon.error] network/ossh:default failed repeatedly: transitioned to maintenance (see 'svcs -xv' for details)


      Everything was working perfectly unless we got some connection refused problem with ssh. Then we have checked the ssh configuration (was everything OK) then restarted the ssh service. The service has started but transitioned to maintenance mode. After that there is no clue to restore back the service.

      Tried with several forum but no one has worked.

      Is there any method to restore back ssh without rebooting the machine?

      Thanks a lot for your support in advance.