6 Replies Latest reply: Oct 3, 2011 2:05 PM by 722901 RSS

    Sort Order Column not Working

    722901
      I have set a sort order column on one of A VARCHAR field, but the functionality is not working. The sorting is enabled in the table view and when I sort by the said column it still sorts based on the VARCHAR values of the column instead of the other INT column I want to sort by. The logical SQL and physical query never even includes the column to sort. Are there any exceptions for the 'Sort Order Column' setting? Is there a config setting or data connections setting that I need to check to make this work?

      Thank You!

      Edited by: VNC on Oct 3, 2011 9:08 AM
        • 1. Re: Sort Order Column not Working
          user248025
          Hi,

          refer below article.

          http://gerardnico.com/wiki/dat/obiee/dashboard_column_sorting


          Thanks

          Deva
          • 2. Re: Sort Order Column not Working
            722901
            I have already enabled sorting in the table properties. The issue is the 'Sort Order Column' Set in the RPD for a column is not working.
            • 3. Re: Sort Order Column not Working
              user248025
              hi,
              can you give me more detailes like some sample column data like below kind

              Like Ex: varchar month column it sould display based on month id
              month : Fev-2011,Dec-2011,jan-2011 and month id 1 to 12


              set your month id as sort order column of month name.

              double click month name ->In general tab set the sort order column as month id

              FYI...see the sample link

              http://www.biconsultinggroup.com/obiee-tips-and-tricks/setting-a-sort-order-column.html

              i hope helped you


              THanks

              Deva

              Edited by: Devarasu on Oct 4, 2011 12:39 AM
              • 4. Re: Sort Order Column not Working
                722901
                Thanks for the response. I have a Usage column in Secs that I'm converting into USAGE(HH:MM:SS) format using a formula and displaying as text. so when the user clicks on the HH:MM:SS column I want to use the Seconds value for sorting. I have set the sort order column on the calculated USAGE(HH:MM:SS) column to Usage field that is in secs. But when I sort the column it still sorts the values treating then as text. eg: 125:34:00 is after 2:30:00
                • 5. Re: Sort Order Column not Working
                  user248025
                  Hi,
                  Please send me your screen short.it will be fine help to fix the solution

                  just for your info:seconds to hh:mm:ss format

                  Re: OBIEE 11g - Change seconds to DD HH:MM:SS format

                  Thanks

                  Deva

                  Edited by: Devarasu on Oct 4, 2011 1:22 AM
                  • 6. Re: Sort Order Column not Working
                    722901
                    I have to use following formula as there is aggregation needed:

                    CAST ( CAST ( TRUNCATE("Usage and Revenue"."Usage Facts"."Usage - Charge" / 3600, 0) AS INTEGER ) AS VARCHAR ( 12 )) || ':' || RIGHT('00' || CAST ( CAST ( TRUNCATE( MOD("Usage and Revenue"."Usage Facts"."Usage - Charge", 3600) / 60, 0) AS INTEGER ) AS VARCHAR ( 2 )), 2) || ':' || RIGHT('00' || CAST ( CAST ( MOD( MOD("Usage and Revenue"."Usage Facts"."Usage - Charge", 3600), 60) AS INTEGER ) AS VARCHAR ( 2 )), 2)