1 Reply Latest reply on Nov 2, 2011 5:10 PM by 889677

    cannot do any new Java installation/Upgrade


      I use windows XP - pro sp3 with java 1.6.19, eclipse and netbeans.

      I also already tried before but since since two days I try once more to find the error which prevents me from installing a new java version. I had Java jdk 1.6.19 installed. It was impossible to install java jdk 1.7 or 1.6.27. First I thought it is a problem with the new java version, but finally - after uninstalliing java jdk 1.6.19 I - cannot reinstall it either, so I cannot install any Java jdk version 1.6.X:

      When ever I try to install Java jdk I get a windows message that the installer has crashed, just in the moment where you can change the directory of installation.
      It crashes if I try to choose another directory or if I try "Next".

      When I ty to install jre1.6.27 or jre1.7.0 there is no problem to install it.

      I closed the java.exe, jqs.exe etc. in memory and did a restarts. Although I can't find any more trace of java jdk 1.6.19, there was still the symbol of Java in the system panel, it did not go away. Clicking on it, it told me that "the system cannot find the registry key specified.
      "HKLM/ Softwàre/javaSoft/JavaRuntimeEnvironment/1.6.0_26"

      I tried to get rid of any java trace and I especially used the following clean programs : free registry cleaner, wise registry cleaner, winSysClean2009 and Tune Up Utilities 2009. I tried JavaRA also, but although it finds some java files to delete, they are not removed.
      I searched the whole registry for the word "java", but I cannot delete all because of JavaScript and my java3D installation and I didn't find anything else.

      Finally - looking in the directory win32 there were still four java files: java.exe; javaw.exe, javacpl.cpl (responsible for the symbol) and javaws.exe.
      So after deleting them and restarting, the symbol has gone, but it still crashes.

      In the technical details the error 0xc00005 is given and besides msiExec.exe the file msihnd.dll, ntdll.dll and some others are cited. All other programs cause no problem with my installer - if I try "modify" the installer opens and I can continue to repair, modify or uninstall the program.
      It seems that this an error of the type "no access possible" because of a corrupt file.

      First I thought it is the java symbol in the control panel, but now the problem is still there.
      I don't see what might be the problem any more, any idea ?

      Why isn't there any effective tool to uninstall completely Java and clean everything ? JavaRA seems not to be very effective, or might there be a problem?

      if I launch the microsoft windows Installer by commandline, the last lines are the following:

      MSI (c) (10:F0) [14:10:34:953]: Note: 1: 2235 2: 3: ExtendedType 4: SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM `CustomAction` WHERE `Action` = 'semicolon'
      MSI (c) (10:F0) [14:10:34:984]: Creating MSIHANDLE (1) of type 790542 for thread 2288
      MSI (c) (10:EC) [14:10:35:031]: Invoking remote custom action. DLL: C:\DOCUME~1\THOMAS~1\LOCALS~1\Temp\MSI9C.tmp, Entrypoint: MSIIsINSTALLDIRValid
      MSI (c) (10:54) [14:10:35:062]: Cloaking enabled.
      MSI (c) (10:54) [14:10:35:078]: Attempting to enable all disabled privileges before calling Install on Server
      MSI (c) (10:54) [14:10:35:109]: Connected to service for CA interface.
      MSI (c) (10!F8) [14:10:35:187]: PROPERTY CHANGE: Modifying SEMICOLON property. Its current value is '0'. Its new value: '1'.
      MSI (c) (10:EC) [14:10:35:281]: Closing MSIHANDLE (1) of type 790542 for thread 2288
      Action ended 14:10:35: semicolon. Return value 1.
      MSI (c) (10:F0) [14:10:35:328]: Internal Exception during install operation: 0xc0000005 at 0x6DA16935.

      So again it is visible that there is an Exception and an error 0xc0000005 but the reason rests a mystery.....

      What I find strange is the following file which I find in %User/LocalSettings/LocalHistory: MsiExec.exe.8cb23528.ini.inuse
      But it is 0 ko and nothing written in it.

      what can I do more? How can I find the reason ?



      Edited by: 886674 on 13 oct. 2011 04:00

      Edited by: 886674 on 13 oct. 2011 05:22

      Edited by: 886674 on 13 oct. 2011 11:24
        • 1. Re: cannot do any new Java installation/Upgrade
          Ok noone saw this posting ? or noone can help me or wants to ? or this is not really a Java problem....

          ok perhaps one of these hypothesis should be right and perhaps it is the latter one...

          ... but now I repaired my system and everything works - also uninstalling the lowest java 1.6 version and replacing it by the last one - and I tried to upgrade to Java 1.7. Despite my perfect system it crashes immediately in the moment where the installation window opens and I try to install it
          with an error message "...encountered an error and has to close now...)

          Is it possible to install Java 1.7 together with 1.6 ? or not ? Is it absolutely necessary to uninstall 1.6 ? without doubt?

          Is it compatible with Windows XP ? or supposed to be used with Windows 7?

          Are there striking differences in Java 7 compared to Java 6 that I may miss ?
          Is Java 7 still in Beta or already the final version now ?

          Thanks for any help