This discussion is archived
2 Replies Latest reply: Oct 17, 2011 12:00 AM by 677079 RSS

Concurrent behavior of DB adapter on SOA 10g Cluster

609722 Explorer
Currently Being Moderated
Hi all,

We have currently setup SOA 10g(10.1.3.5.2) cluster.According to Oracle documentation other than File/FTP adapters all other adapters behave concurrently i.e; we can have these adapters in active-active topology in the cluster.

Now we have a built a sample ESB project with inbound DB adapter and two routing rules.One invoking a BPEL process and another creating a File.

We have the DB adapter in active-active mode.Now at runtime when we insert some record into a table polled by the above DB adapter, we find that duplicate BPEL instances are created and duplicate files get created(on both application hosts).

However if I change the active-active topology of the adapter into active-passive topology by inserting clusterGroupId property on endpoint of the adapter then only a single BPEL instance and single File is created.

Please let us know how we can achieve the above with active-active mode of the adapters.

Thnks & Rgds,
Mandrita
  • 1. Re: Concurrent behavior of DB adapter on SOA 10g Cluster
    Anuj Dwivedi Guru
    Currently Being Moderated
    Please refer section "5.15 How Do I Enable Distributed Polling for an Inbound Database Adapter?" at -

    http://www.oracle.com/technetwork/topics/soa/oracle-soa-suite-ha-faq-1-131459.pdf

    Regards,
    Anuj
  • 2. Re: Concurrent behavior of DB adapter on SOA 10g Cluster
    677079 Newbie
    Currently Being Moderated
    Hi Anuj,

    Thanks for your response. However when we enabling distributed polling then we find that the behavior is not consistent.

    I am explaining the inconsistency below-

    When ESB_DT with service-weight=100 is up then ESB to BPEL invocation(SOAP) creates duplicate BPEL instances but when I shutdown that ESB_DT and the other ESB_DT with service-weight = 50 goes up then we find that duplicate BPEL instances are not getting created.

    So is this a default behavior i.e; active-active topology behavior is not consistent?

    Thnks & Rgds,
    Mandrita

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points