This discussion is archived
3 Replies Latest reply: Oct 19, 2011 4:01 AM by Shixiang ZHOU RSS

TSAM error reading the TUXCONFIG file

895062 Newbie
Currently Being Moderated
Hi,

I recently began experimenting with TSAM and had some initial troubles with the configuration. The LMS server would start successfully, but after starting the TSAM manager (default apache-tomcat server) I received the following error in my ULOG.

154127.machine!LMS.18500.8624.1: LIBTUX_CAT:607: ERROR: Cannot open section MACHINESSECT of the TUXCONFIG: -1

I found that the LMS server was attempting to read the TUXCONFIG file from an invalid location. It always truncated the path of the file to 8 characters. For example, if I stored the tuxconfig file at "C:\TSAM\tuxconfig" it would attempt to read the file "c:\TSAM\t". When this file didn't exist, it would create a file in its place (with some additional characters) and log the above error in the ULOG. This would happen ~8 times per second. After I shorted the full file name to less than 8 characters (e.g. "c:\tc") the agent connected to the manager successfully and I was able to begin using the functionality. Here are some of the file names created when the server could not find the file - "tuxcoP¾`", "tuxcoP¾_", "doоf", "dopùb", etc.

Does anyone have any ideas what would cause this type of problem? I am running Windows 7 64-bit using Tuxedo 11gR1, also 64-bit.

Thanks!

Jonathan
  • 1. Re: TSAM error reading the TUXCONFIG file
    650738 Newbie
    Currently Being Moderated
    Jonathan,
    Can you tell me the platform you tried?

    Yu Wang
  • 2. Re: TSAM error reading the TUXCONFIG file
    Todd Little Expert
    Currently Being Moderated
    Hi Jonathan,

    Windows 7 is not a supported Tuxedo server platform. The only thing supported on Windows 7 is the Tuxedo client installation. Can you try this on a supported platform such as Windows Server 2008?

    Regards,
    Todd Little
    Oracle Tuxedo Chief Architect
  • 3. Re: TSAM error reading the TUXCONFIG file
    Shixiang ZHOU Newbie
    Currently Being Moderated
    Jonathan,

    I just run Tuxedo 11gR1 (11.1.1.2.0)/TSAM 11gR1 (11.1.1.2.2) under Windows 7 64bit machine. No any problem observed.

    My steps,
    1)     Download 32bit installers for both Tuxedo 11gR1 (11.1.1.2.0)/TSAM 11gR1 (11.1.1.2.2);
    2)     Install Microsoft Visual C++ 2008 Express Edition;
    3)     Run simpapp with TSAM;

    Platform:
    Windows 7 64bit machine

    NOTE:
    If you download 64bit installer for Tuxedo 11gR1 (11.1.1.2.0)/TSAM 11gR1 (11.1.1.2.2), you might fail to compile client/server for simpapp example at Windows 7 64bit machine.

    Therefore, we suggest you download 32bit installers for both Tuxedo 11gR1 (11.1.1.2.0)/TSAM 11gR1 (11.1.1.2.2), and try again.

    setenv.cmd
    ========
    call "C:\VS90\VC\bin\vcvars32.bat"

    set TUXDIR=C:\bea\tuxedo11gR1
    set APPDIR=C:\bea\tuxedo11gR1\samples\atmi\simpapp
    set PATH=%TUXDIR%\bin;%APPDIR%;%PATH%
    set TUXCONFIG=%APPDIR%\tuxconfig

    Ubbsimp
    ==========

    *RESOURCES
    IPCKEY          123456

    #Example:
    #IPCKEY          123456

    DOMAINID     simpapp
    MASTER          simple
    MAXACCESSERS     10
    MAXSERVERS     5
    MAXSERVICES     10
    MODEL          SHM
    LDBAL          N

    *MACHINES
    DEFAULT:
              APPDIR="C:\bea\tuxedo11gR1\samples\atmi\simpapp"
              TUXCONFIG="C:\bea\tuxedo11gR1\samples\atmi\simpapp\tuxconfig"
              TUXDIR="C:\bea\tuxedo11gR1"

    "YourMachine"     LMID=simple

    *GROUPS
    GROUP1
         LMID=simple     GRPNO=1     OPENINFO=NONE

    *SERVERS
    DEFAULT:
              CLOPT="-A"

    simpserv     SRVGRP=GROUP1 SRVID=1

    LMS SRVGRP=GROUP1 SRVID=90 CLOPT="-A -- -l localhost:8080/tsam" RESTART=N

    *SERVICES
    TOUPPER

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points