3 Replies Latest reply: Oct 24, 2011 4:33 PM by 894901 RSS

    Applying Solaris 10 Update 9 to system running only Update 7

    894901
      Hi, is it ok to go from Update 7 to Update 9 or even Update 10? When I attempt this, the "upgrade" appears to succeed, but it doesn't seem to install anything. It's strange. The package list it says it's going to install is empty. I attempted this by attaching the .iso (this is a VM I'm updating) and then running the installer directly from the cdrom drive. I've also tried to boot from the cdrom drive with the update 9 iso attached, but it appears to want to do a new installation over the old.

      I don't currently have access to get Update 8 or I'd just try that, so I'm stuck at the moment. Thanks for any input.
        • 1. Re: Applying Solaris 10 Update 9 to system running only Update 7
          894901
          I just noticed that my /cdrom/sol_10_910_x86/Solaris_10/Patches directory has no files in it. Would this explain why my upgrade is failing? Well, it's not failing, it's saying it's successful but nothing is getting installed. The ../Product directory has many packages, but not the Patches directory.
          • 2. Re: Applying Solaris 10 Update 9 to system running only Update 7
            Alan.S-Oracle
            No, the patches directory is used only when a post-installation patch is required, which has not been the case with Solaris updates in a long time.

            To answer your original question, you can perform an upgrade from Update 7. What upgrade option did you choose? You said you ran the installer directly. Does this mean that you did not boot off of the install media, which is the proper way to install or upgrade a Solaris 10 system?

            -- Alan
            • 3. Re: Applying Solaris 10 Update 9 to system running only Update 7
              894901
              Thanks for the reply. I found out the disks weren't the actual patch bundles, but full OS installations.

              So, I did end up getting the patch bundles, and I've launched it (Update 9, x86) and it's been stuck on the 3rd patch for about 1hr now. It's patch 119255-76. SHould a single patch in a patch bundle take this long? This is running Solaris 10, update 7 in a VM, applying patch bundle 10_x86_0910. It's driving me nuts because, if' it's actually stuck, I'm just wasting time waiting for it. Anyone have experience with this patch? THanks.