1 2 Previous Next 15 Replies Latest reply on Oct 10, 2012 1:51 PM by 946142

    Enterprise Manager 12c 32BIT

    Rabbit (user528481)
      Has anyone managed to install the 32bit version?

      I can't get past the OMS Configuration and it seems it cannot allocate enough memory for the JVM process. All prereq checks are happy with 4GB of RAM, even allocated 5GB RAM to it since the installer itself takes roughly 1GB, but still no luck.
        • 1. Re: Enterprise Manager 12c 32BIT
          Yes what exactly the issue, could you please explain
          • 2. Re: Enterprise Manager 12c 32BIT
            Rabbit (user528481)
            Last couple lines from the omsca.log

            Oct 28, 2011 3:22:57 PM oracle.sysman.omsca.adapter.wls.OMSWLSAdapter adapterCleanup
            FINE: Cleaning the OMS from the repository
            Oct 28, 2011 3:22:58 PM oracle.sysman.omsca.adapter.wls.OMSWLSAdapter adapterCleanup
            FINE: Got the Host URL as: null
            Oct 28, 2011 3:22:58 PM oracle.sysman.omsca.framework.OMSGenericAdapter postDeployAndReposSetup
            SEVERE: OMSCA-ERR:Post "Deploy and Repos Setup" operations failed. Check the trace file:/u01/oracle/product/middleware/oms/cfgtoollogs/omsca/omsca_20111028150320.log
            Oct 28, 2011 3:22:58 PM oracle.sysman.omsca.framework.OMSCAFreshInstall execute
            SEVERE: Post "Deploy and Repos Setup" operations failed.
            Oct 28, 2011 3:22:58 PM oracle.sysman.omsca.framework.OMSConfigAssistantDriver main
            FINE: Got resultfalse

            from the EMGC_OMS1.out file:

            Error occurred during initialization of VM
            Could not reserve enough space for object heap
            Could not create the Java virtual machine.
            <Oct 28, 2011 3:22:12 PM> <FINEST> <NodeManager> <Waiting for the process to die: 7385>
            <Oct 28, 2011 3:22:12 PM> <INFO> <NodeManager> <Server failed during startup so will not be restarted>
            <Oct 28, 2011 3:22:12 PM> <FINEST> <NodeManager> <runMonitor returned, setting finished=true and notifying waiters>
            • 3. Re: Enterprise Manager 12c 32BIT
              Whats the swap space
              • 4. Re: Enterprise Manager 12c 32BIT
                Rabbit (user528481)
                5GB, but not a single KB is used of that. Running Oracle Linux 6.1 freshly installed.
                • 5. Re: Enterprise Manager 12c 32BIT
                  OEl6 is not supported. Please check the certification metric at metalink.
                  • 6. Re: Enterprise Manager 12c 32BIT
                    Yeah well, there are plenty people which still try it. Entire step-by-step guides can be found on the net. Since it's not a production system (otherwise i'd have more recources available), i'm not too worried about certification and was hoping for a bit more useful hints.

                    64bit works, even on my 4GB of RAM. Looking at top and ps, i'd say the single java process which gets started runs out of memory as it grows pretty much to the 2GB limit.
                    • 7. Re: Enterprise Manager 12c 32BIT
                      Simon Haslam
                      Interesting - I'm running into the same issue on 32 bit OL 5.7 UEK.

                      The WebLogic EMGC_OMS1 managed server is being started with these memory parameters:
                      -Xms256m -Xmx1524m -XX:MaxPermSize=612M

                      If you look at the admin server (EMGC_ADMINSERVER) you'll see it is started with
                      -Xms256m -Xmx512m -XX:MaxPermSize=512m

                      So between those two there's 512-2GB used for just the OMS JVMs.

                      I suppose the question is how much memory can a process allocate under 32 bit OL? I think this is something like 1.7GB without hugemem/pages - that looks like it should be OK given the max heap size above. The 12c installer pre-reqs are 3900MB memory and probably similar for swap.

                      In my case I also have a 11.2 database running on the same VM - its SGA was about 0.5GB.

                      Think I'm going to bump up the vMem and swap and try again (though based on your experiences I'm not holding my breath!).

                      • 8. Re: Enterprise Manager 12c 32BIT
                        Simon Haslam
                        Actually of course I should have been adding the PermGen space on top of the java heap... the JVM process is then looking like it needs over ~2.1GB.

                        Anyway, I just tried starting WebLogic manually (using the command it was using - just copy from the EMGC_OMS1.out log file if you want to try) and, sure enough, the managed server won't start up. The only way you can get it to start is to drop the max heap size or max PermGen size by about 350MB!

                        (OMSCA deletes all the domain etc config from under gc_inst after the failure has occurred so you can't just run up the servers with node manager).

                        Assuming the mx and MaxPermSize parameters are fixed in the installer somewhere (rather than being set dynamically according to memory) I can't see how this can being working for anyone on Linux 32 bit!

                        Surely Oracle wouldn't release software on a platform that hasn't been though any regression tests and doesn't even install..?!
                        • 9. Re: Enterprise Manager 12c 32BIT
                          Simon Haslam
                          I've come up with a workaround to allow you to install OEM CC 12.1 on 32 bit Linux (in this example, I'm using OL 5.7 UEK).

                          1) Run the OEM CC installer but choose to install software only

                          2) Edit the file <ORACLE_HOME>/oms/sysman/omsca/scripts/wls/create_domain.py which sets the Managed Server JVM startup parameters:
                          - change -Xmx1524m to -Xmx1324m
                          - change -XX:MaxPermSize=612M to -XX:MaxPermSize=412M
                          If you look at the comments in the file you'll see that various values have been tweaked between 11g and 12c releases (and actually the 612 is a typo for 512MB anyway).

                          3) Run <ORACLE_HOME>/oms/sysman/install/ConfigureGC.sh and enter details as you would normally.

                          You wouldn't do this on a production system of course (raise an SR instead, but then again production is almost certainly going to be 64 bit anyway) but it seems to work OK on a test laptop.

                          Hope this helps,

                          • 10. Re: Enterprise Manager 12c 32BIT
                            Hi Simon,

                            I don't see why you needed such a tweak. I've installed em12c to my virtual linux box (OEL 5.6 32bit) right after it's released:


                            I didn't need any tweaks? Could it be something about UEK?


                            • 11. Re: Enterprise Manager 12c 32BIT
                              Simon Haslam
                              Thanks for the update Gokhan.

                              Well, assuming we're both using the JDK 6 (1.6.0_24) provided in the OEM 12.1 download, then I guess it must be a difference between your Oracle Enterprise Linux R5 U6 (you were using the default Red Hat kermel presumably?) and my Oracle Linux R5 U7 UEK (default now).

                              It looks as though the memory parameters have been tweaked on 32 bit to make them as big as possible and this might change slightly between JVM and kernel revisions.
                              • 12. Re: Enterprise Manager 12c 32BIT
                                Yes I use the default redhat kernel, and I installed oracle-validated package. As I know it modifies the kernel settings. This could also make a difference.
                                • 13. Re: Enterprise Manager 12c 32BIT
                                  Simon Haslam
                                  Yes, I used the oracle validated RPM (oracle-validated-1.1.0-14.el5) too for convenience when installing an EE database on the same VM for the repository. It'll be interesting to hear if anyone else has have such issues with 32 bit (other than Rabbit and user11982958). Unfortunately, even on a Core i7 and SSD, the configuration stage takes a good 30-45 mins or so to fail so really you need to try starting a JVM with comparable settings beforehand.
                                  • 14. Re: Enterprise Manager 12c 32BIT
                                    Simon Haslam
                                    Note I've just successfully completed a clean install of the new BP1 release on 32 bit OL 5.7.

                                    The <ORACLE_HOME>/oms/sysman/omsca/scripts/wls/create_domain.py file still had the old memory settings, which I'm pretty sure won't work on this OS. I didn't want to waste my time so set them to the lower values as I described earlier in this thread and the configure was fine.

                                    If anyone else is installing OEM 12c on a 32 bit Linux please post your experiences here.
                                    1 2 Previous Next