2 Replies Latest reply on Nov 17, 2011 10:54 PM by 900827

    SQL Developer won't start

      I downloaded the latest version of SQL Developer ( 64 bit, onto my computer running Windows 7 Home Premium (x64). I unzipped it to Program Files, and tried to run. I got asked for the path to my Java SDK, which I browsed to and selected. I have Java SDK version 1.7.0_01-b08. It said that it might not be compatible with that version, and I should use an older version, but I pressed "try anyway". It gave me an error, saying MSVCR71.dll is missing, and I should try reinstalling. When I press OK on that, it says Unable to launch Java Virtual Machine, located at: ..\..\jdk\jre\bin\client\jvm.dll. I also tried downloading and installing the 32 bit version, which includes the Java SDK, but have the same problem. I have searched online and found similar but not exact issues, and haven't found a solution. Do I need to install software that includes the DLL, or the Virtual Environment? I would just like to use this program, it's for a class, I don't need any additional Java software or development tools unless it's required to get this working. Thanks
        • 1. Re: SQL Developer won't start
          Gary Graham-Oracle

          First off, please make sure the versions of SQL Developer and Java SDK match in terms of bit-architecture, either both 32 or both 64. You can explicitly control the Java SDK that SQL Developer points to from the ...\sqldeveloper\bin\sqldeveloper.conf file. As for the missing dll, if it should still be a problem, try finding it in your Java SDK install and copy it to the same directory as sqldeveloper.conf.

          Keep in mind you can install as many versions of the Java SDK as you wish on your machine and switch between them as desired using the conf file, as noted above.

          SQL Developer Team
          • 2. Re: SQL Developer won't start
            I downloaded the DLL and it fixed both problems, thanks. I would have taken this step earlier but I figured it would probably cause more problems, more missing DLLs, and thought there was probably some software missing. Thanks.