Forum Stats

  • 3,686,736 Users
  • 61,104 Discussions
  • 206,416 Comments

Discussions

Check out Oracle NetSuite upcoming events and conferences here
Now is the time to ask your NetSuite-savvy friends and colleagues to join the NetSuite Support Community! Refer now!
RUN, DON’T WALK...Registration for #SuiteWorld 2022 is officially OPEN! This special early bird price won’t last long, so make sure you don’t miss out: https://lnkd.in/gGRN78A3
Virtual Event: Getting the Most Out of NetSuite Standard Costing Capabilities

You asked for it, you got it! Join the webinar Getting the Most out of NetSuite Standard Costing Capabilities on June 28, 2022 at 11AM PT. Register here!

Error “Field match doc not found on record type” for NetSuite REST API, apply sublist

edited Jun 19, 2020 6:48PM in Ask A Guru 7 comments

I'm receiving the following error when trying to access the apply sublist, on either a customerpayment or creditmemo record, using the NetSuite records REST API.

Field match doc not found on record type CustomerPayment:CustomerPaymentApplyLine Error ID: kb044otyp049ezuy6pjh

The url path I'm executing is /record/v1/customerpayment/57144/apply

I'm using NetSuite cloud, sandbox.

I've tried the following:

  • Using the expandSubResources and expand parameters, to see if I can indirectly access the sublist records.
  • I've added all permissions which appear remotely relevant for this API to the profile used by the integration account.
  • I tried using the fields parameter, to retrieve a specific field from the apply sublist, on the theory that the doc field is creating the problem. Although, it is a the doc field that I need to access.
Tagged:

Howdy, Stranger!

Log In

To view full details, sign in.

Register

Don't have an account? Click here to get started!

Leaderboard

This Week's Leaders

This Month's Leaders

All Time Leaders