Forum Stats

  • 3,872,697 Users
  • 2,266,459 Discussions
  • 7,911,285 Comments

Discussions

Unable to access Business Rules Facts after refreshing XML Facts

716701
716701 Member Posts: 4
edited Jan 7, 2010 10:29AM in BPEL
I have created a business rule using an xml schema to generate the XML Facts. Then I created a Decision Function to call a Ruleset to process the information in the XML Facts. This decision function has input and ouput parameters from the XML Facts.
The decision function is used inside a BPEL Process, by defining the Dictionary has the created business, defined the Service has de Decision Service. After this configuration I'm able to define the Input Facts and Output Facts from and to a variable in the bpel process. Using the Decision Fact Map window I define the input and output to the exposed Business Rule Facts. This works just fine. The BPEL runs and the Rules are correctly used.

When I change my xml schema to add more elements and complex types I use the "Reload XML Facts From Updated Schemas" option available in the bussiness rule. After this operation I will no longer have access to the Bussiness Rule Facts in the Decision Fact Map window. So I'm no longer able to call the decision function.
Yet the business rule has no problems and i have tested using a fuction to call the Decision Function.

Is this a bug or a feature?

I'm using Oracle 11g with the SOA Composite Editor 11.1.1.0.0.52.19.

Answers

  • 716701
    716701 Member Posts: 4
    Problem solved. There was an element in the xml schema that had nillable = true. Because of this the XML Fact for that element would no longer be available in the BPEL Process. Removing the nillable and generating the XML Facts again solved the missing variable problem.
This discussion has been closed.