Forum Stats

  • 3,874,263 Users
  • 2,266,716 Discussions
  • 7,911,794 Comments

Discussions

Open Wrokbook from Command line from Oracle Forms

3004
3004 Member Posts: 204,171 Green Ribbon
I've recently found out a sheet opens up correctly when sign on as the schema owner of the workbook, but not when signed on as another user.

It appears the command line options do not include a parameter to handle the
dialogue box asking "Open the workbook in the current database account?".

This perhaps is a bug? Unless someone has some insight on this?
Thanks in advance.
Gregg

Comments

  • 3004
    3004 Member Posts: 204,171 Green Ribbon
    I recommend that you login as the owner of the workbook and then share the workbook to the other users (or to PUBLIC). That way any user can open it by referring to the workbook as <ownerid>.<workbook name> and this should avoid the extra dialog.

    Hope this helps,
    Oracle Discoverer Team http://technet.oracle.com

    <BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by GREGG SAKSEFSKI ([email protected]):
    I've recently found out a sheet opens up correctly when sign on as the schema owner of the workbook, but not when signed on as another user.

    It appears the command line options do not include a parameter to handle the
    dialogue box asking "Open the workbook in the current database account?".

    This perhaps is a bug? Unless someone has some insight on this?
    Thanks in advance.
    Gregg
    <HR></BLOCKQUOTE>

    null
  • 3004
    3004 Member Posts: 204,171 Green Ribbon
    Actually the solution that worked for me I received from the following response from ODTUG-DISK2K-L:
    Gregg,
    Turn off the option to display a warning when opening a workbook saved in a
    different database account. Also, if the workbook name contains a period,
    then the name must be enclosed in single quotes. I have that option turned
    off and I have used the following command line successfully:

    dis31usr.exe /opendb <schemaowner>.'workbook.name' /sheet all

    Jean Russell
    University of New Mexico

    <BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by Oracle Discoverer Team:
    I recommend that you login as the owner of the workbook and then share the workbook to the other users (or to PUBLIC). That way any user can open it by referring to the workbook as <ownerid>.<workbook name> and this should avoid the extra dialog.

    Hope this helps,
    Oracle Discoverer Team http://technet.oracle.com

    <HR></BLOCKQUOTE>
This discussion has been closed.