Forum Stats

  • 3,782,050 Users
  • 2,254,585 Discussions
  • 7,879,901 Comments

Discussions

ora-7445 when starting SmbServer

3004
3004 Member Posts: 204,171
On startup of the SmbServer process the following query is issued to table odus_accesscontrollist which causes an ORA-7445 error. Because of this error the SmbServer process receives ora-03113 and is disconnected. If I connect locally to the database where ifs is installed and query the OWNER column from ODUS_ACCESSCONTROLLIST this also triggers the ORA-07445 error. Any suggests for where to look next or how to approach this problem?

select x.id, x.classid, x.NAME, x.DESCRIPTION, x.OWNER, x.ACL, x.FAMILY, x.RESOLVEDPUBLICOBJECT, x.CREATEDATE, x.CREATOR, x.LASTMODIFYDATE, x.LASTMODIFIER, x.DELETOR, x.POLICYBUNDLE, x.PROPERTYBUNDLE, x.ADMINISTRATIONGROUP, x.SECURINGPUBLIC
OBJECT, x.EXPIRATIONDATE, x.LOCKSTATE, x.FLAGS, x.LOCKEDFORSESSION, x.DIRECTORYU
SER, x.HOMEFOLDER, x.DEFAULTACLS, x.DEFAULTADMINGROUP, x.READINDICATIONSTATE, x.CONTENTQUOTA from odms_primaryuserprofile x where ((x.owner = :1 and x.odmz_user
id = 0) or (x.owner != :2 and x.odmz_userid = 1) or (x.owner != :3 and x.odmz_us
erid = :4)) and DIRECTORYUSER = :5

Comments

  • 3004
    3004 Member Posts: 204,171
    Found out via tech support that I was running into known bug # 1161174 which is triggered when you are using the partitioning option along with sql_trace set to true at the database level. The bug will not be addressed until 8.1.7. The work-around suggested was to not use partitioning OR turn off sql tracing. I chose to remove sql_trace = True from the init.ora.

    SmbServer has now started successfully
This discussion has been closed.