On January 27th, this site will be read-only as we migrate to Oracle Forums for an improved community experience. You will not be able to initiate activity until January 30th, when you will be able to use this site as normal.

    Forum Stats

  • 3,889,552 Users
  • 2,269,759 Discussions


Getting "Generic Errors" while using JCA file adapter for reading in OSB

811390 Member Posts: 4
edited Aug 1, 2013 1:37PM in Integration - Adapters
Hello All,

I am using OSB 11g ( to create an integration interface that reads a file using JCA file adapter read method (polling read every 1 min). I am reading an XML file. It works all fine and Adapter invokes my Proxy as long as file size is somewhere in the range of 300 KB to 500KB. But as soon as I increase size beyond that I get below error

<Info> <JCA_FRAMEWORK_AND_ADAPTER> <osb_server1> <[STUCK] ExecuteThread: '4' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <3d7f9cebf2eef936:-176b445f:12eca9197cb:-8000-00000000000031e1> <1300559004810> <BEA-000000> <Generic Error caught while translating inbound file in streaming mode : WSCHEMA_BIG_ORDERS.xml
at oracle.tip.adapter.file.inbound.InboundTranslatorDelegate.xlate(InboundTranslatorDelegate.java:292)
at oracle.tip.adapter.file.inbound.InboundTranslatorDelegate.doXlate(InboundTranslatorDelegate.java:118)
at oracle.tip.adapter.file.inbound.ProcessorDelegate.doXlate(ProcessorDelegate.java:377)
at oracle.tip.adapter.file.inbound.ProcessorDelegate.process(ProcessorDelegate.java:175)
at oracle.tip.adapter.file.inbound.ProcessWork.run(ProcessWork.java:349)
at weblogic.work.ContextWrap.run(ContextWrap.java:41)
at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:528)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)

I tried both with and without providing schema for the payload and no difference. Also tried latest install of Fusion with same results.

Any ideas anybody? To me it looks like perhaps some settings issue....not sure why this error entry has qualifier [STUCK], is it because some resource/setting is making thread stuck etc. underlying JVM has 8 GB heap size so that may not be issue.

Only thing left to try is reading File as attachment but with that it seems I cant do transformations on payload so that wont help...also I think 500 KB is tiny thses days (considering some folks process 1GB payloads through OSB)

Any help is appreciated.

Thanks in advance


Edited by: 808387 on Mar 22, 2011 12:11 AM


  • 846288
    846288 Member Posts: 8
    Please set the logging level to finest and post logging message before this exception.
  • 846288
    846288 Member Posts: 8
    Try using "oracle.tip.adapter.file.inbound.FileActivationSpec" class as ActivationSpec class.

  • 811390
    811390 Member Posts: 4
    edited Mar 22, 2011 4:38PM

    Thanks for the reply.

    Here are log lines preceeding the actual error

    ####<Mar 22, 2011 1:32:59 PM PDT> <Debug> <AlsbJcaFrameworkAdapter> <nke-lnx-int-d001> <osb_server1> <[STUCK] ExecuteThread: '10' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <3d7f9cebf2eef936:-4cc64194:12edf142231:-8000-0000000000000141> <1300825979354> <BEA-000000> <Poller enqueuing file for processing :/tmp/poc/BIG_FILE.xml>
    ####<Mar 22, 2011 1:32:59 PM PDT> <Debug> <AlsbJcaFrameworkAdapter> <nke-lnx-int-d001> <osb_server1> <[STUCK] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <3d7f9cebf2eef936:-4cc64194:12edf142231:-8000-00000000000002c6> <1300825979354> <BEA-000000> <File : /tmp/poc/BIG_FILE.xml is ready to be processed. >
    ####<Mar 22, 2011 1:32:59 PM PDT> <Debug> <AlsbJcaFrameworkAdapter> <nke-lnx-int-d001> <osb_server1> <[STUCK] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <3d7f9cebf2eef936:-4cc64194:12edf142231:-8000-00000000000002c6> <1300825979362> <BEA-000000> <shouldProcessMessage: error = false --> true>
    ####<Mar 22, 2011 1:32:59 PM PDT> <Debug> <AlsbJcaFrameworkAdapter> <nke-lnx-int-d001> <osb_server1> <[STUCK] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <3d7f9cebf2eef936:-4cc64194:12edf142231:-8000-00000000000002c6> <1300825979413> <BEA-000000> <Setting payloadThreshold[-1] on translation context>
    ####<Mar 22, 2011 1:32:59 PM PDT> <Debug> <AlsbJcaFrameworkAdapter> <nke-lnx-int-d001> <osb_server1> <[STUCK] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <3d7f9cebf2eef936:-4cc64194:12edf142231:-8000-00000000000002c6> <1300825979414> <BEA-000000> <Invoking inbound translation for : BIG_FILE.xml>
    ####<Mar 22, 2011 1:32:59 PM PDT> <Debug> <AlsbJcaFrameworkAdapter> <nke-lnx-int-d001> <osb_server1> <[STUCK] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <3d7f9cebf2eef936:-4cc64194:12edf142231:-8000-00000000000002c6> <1300825979414> <BEA-000000> <InboundTranslatorDelegate:: Scalable DOM Created>

    About the activation class you mentioned
    Thats the same class that I am using. Its what default was. The JCA looks like below

    <adapter-config name="TestBigFile" adapter="File Adapter" wsdlLocation="TestBigFile.wsdl" xmlns="http://platform.integration.oracle/blocks/adapter/fw/metadata">

    <connection-factory location="eis/FileAdapter" UIincludeWildcard="BIG*" adapterRef=""/>
    <endpoint-activation portType="Read_ptt" operation="Read">
    <activation-spec className="*oracle.tip.adapter.file.inbound.FileActivationSpec*">
    <property name="UseHeaders" value="false"/>
    <property name="PhysicalDirectory" value="/tmp/poc"/>
    <property name="Recursive" value="true"/>
    <property name="DeleteFile" value="true"/>
    <property name="IncludeFiles" value="BIG.*"/>
    <property name="PollingFrequency" value="60"/>
    <property name="MinimumAge" value="0"/>



    Edited by: 808387 on Mar 22, 2011 1:36 PM

    Edited by: 808387 on Mar 22, 2011 1:37 PM
  • imsammyd
    imsammyd Member Posts: 31 Blue Ribbon
    Did you ever find a solution? We are facing the same problem.

  • 843817
    843817 Member Posts: 1
    Did you find the solution?

    I am having the same problem. We are using OSB

    Any suggestions will be greatly appreciated.

  • Baan, Jos
    Baan, Jos Member Posts: 65
    Do you need translation/validation on the payload? In that case you can never became even close to the 1GB you mention. If you want to process big files like that, you can only achieve this through the referencing option and in that case no transformation is possible. In fact, the file will be streamed...

    So, having mentioned this, the problem you encounter can be caused by the restrictions on the protocol. I assume you are running WebLogic server. check on the Domain settings if the max size of the protocols are (nearly) reached.

  • sri_kun
    sri_kun Member Posts: 80

    Hi jos,

    In ourcase we are getting the same error and we are trying to read the file with de-batching (100 per batch) and placing a CSV file with 5000 records and just place all the recs in the db.

    But it is gettig error out as below:

    <BEA-000000> <Generic Error caught while translating inbound file  in streaming mode  : xxxxxxxxxx.csv


    Any idea or help can be appreciated.



This discussion has been closed.