Forum Stats

  • 3,827,551 Users
  • 2,260,791 Discussions
  • 7,897,297 Comments

Discussions

User variable of Date type

sj1208
sj1208 Member Posts: 160
edited Apr 8, 2013 6:03AM in Planning and Budgeting
Hi,

Iam trying to create a user variable of "Date as Number". Iam able to give he default value in the format YYYYMMDD. But when i give a value of 31 for DD, (eg: 20131231) system is not accepting.Not accepting 31 for any month and it throws a pop warning asking to use the format of YYYYMMDD. Is there any workaround. Am I making any mistake here.?

thanks

Answers

  • Celvin Kattookaran
    Celvin Kattookaran Member Posts: 3,143 Gold Trophy
    Instead of manually typing the values, use the calendar and see whether that works.

    Regards

    Celvin

    http://www.orahyplabs.com

    Please mark responses as helpful/correct if applicable
  • sj1208
    sj1208 Member Posts: 160
    calender pops up only in data form when we have a member of data type date. Here in variable designer there is only provision to type manually. it is accepting if i give 20131230, upto 30the day for any month its accepting, but its not accepting a value of 31.

    thanks,
  • Celvin Kattookaran
    Celvin Kattookaran Member Posts: 3,143 Gold Trophy
    Which version are you using? I can create a variable with default value 20131231.

    You can leave the default value blank, it'll show a warning while validation (however you can ignore this).

    Regards

    Celvin

    http://www.orahyplabs.com

    Please mark the responses as helpful/correct if applicable
  • sj1208
    sj1208 Member Posts: 160
    Hi Celvin,

    Iam using 11.1.2.1 version. Yes i can leave it blank , but iam supposed to give a defaut value for the user which would be the last day of the year. But when i try to give 20131231 as default value, it throws a pop up asking me to fill in proper format of YYYYMMDD. It doesnt shoe this message if i keep the date to anything less than 31.

    thanks,
  • Celvin Kattookaran
    Celvin Kattookaran Member Posts: 3,143 Gold Trophy
    I tried that on 11.1.2.2 and it works fine there. So it could be a bug, I would recommend to log an SR if not done already.

    There could be a patch available for this.


    Regards

    Celvin

    http://www.orahyplabs.com


    Please mark responses as helpful/correct if applicable
    Celvin Kattookaran
  • sj1208
    sj1208 Member Posts: 160
    Thanks Celvin for you efforts. I even tried it another 11.1.2.1 environment, but still got the same error. So i believe this could be a bug. I ll report back once i get to some solution or workarounds from oracle.

    thanks
  • sj1208
    sj1208 Member Posts: 160
    Hi Celvin,

    I got a call from Oracle support, accepting this as an issue with not solution or workaround at present. However since this problem doesnt exisit in 11.1.2.2 , i dunno if they would release a patch soon. They ve said they wd try to create an enhancement request. Ill update if something turns up from their side.

    Thanks,
This discussion has been closed.