Forum Stats

  • 3,826,885 Users
  • 2,260,721 Discussions
  • 7,897,114 Comments

Discussions

No portlets in portlet producer

MichaelBaygeldin
MichaelBaygeldin Member Posts: 30
edited Apr 19, 2013 1:53AM in WebCenter Portal
Hello Experts!
I have a question about Portlet Producers.

I made simple Framework Application in JDeveloper (I also made WSRP Producer Connection in JDeveloper). Then I tried to run my application (locally) and everything was fine: I see my portlet in Composer.
But then I tried to deploy my application (remote deployment) and now there is no my portlet in Portlet Producer. It just writes "Empty folder" in Composer...

(In both cases portlet producer connection is OK. I checked this in application administration console.)

How can I fix this? Any idea?

Answers

  • ngsankar
    ngsankar Member Posts: 669
    have you added/created the portlets to the application from em console, if not consume the portlet using wsdl on em conosle>>your appliation>>rightclick>>system config>portlet producer here register it
  • I am not an author of this portlet. I just have wsdl link. As far as I know this portlet is deployed somewhere on remote WebLogic Server. Using this WSDL link I created WSRP Producer connection in JDeveloper.

    I checked EM and my producer is there.

    I can register portlet producer in runtime (through application administration console) and everything will be fine. But I really want to use portlet producer created in JDeveloper.
  • ngsankar
    ngsankar Member Posts: 669
    i have never tried this option from jdeveloper, but it should work as per the oracle documentation,
    just try to remove the mds and deploy the application again? i will try to test in my lab :)
  • If I remove the mds I will lost my Portlet Producer created at run-time. Even though I will have my Portlet Producer created from JDeveloper it will be empty as in previous case.
This discussion has been closed.