Forum Stats

  • 3,816,028 Users
  • 2,259,131 Discussions
  • 7,893,366 Comments

Discussions

Running emcli setup -url=https://nsn175-105.us.oracle.com:7803/em -username=SYSMAN

user13475271
user13475271 Member Posts: 19
edited Oct 22, 2013 4:49PM in Enterprise Manager

Hello all,

First thank you for all your helps with previous questions.

Right now I am encountering an issue when I run emcli setup -url=https://nsn175-105.us.oracle.com:7803/em -username=SYSMAN in a terminal where I logged in using my oracle account or a local account created on a Linux (2.6.32-100.28.5.el6.x86_64) running on SunRay.

Oracle Enterprise Manager Cloud Control 12c : 12.1.0.3.0

JAVA_HOME=/usr/java/jdk1.7.0_40

PATH=/usr/java/jdk1.7.0_40:$PATH

When I logged in as a root, the emcli setup is successful. The question I have is: how to fix this following error so I can setup emcli successfully? Thank you in advance.

lf

--------------------------------------------------------------------------------

The error message for non-root users:

./emcli setup -url=https://nsn175-105.us.oracle.com:7803/em -username=SYSMAN

Oracle Enterprise Manager 12c 3.

Copyright (c) 1996, 2013 Oracle Corporation and/or its affiliates. All rights reserved.

The configuration directory "/home/user_name" may not be local. See the "dir" option in the help for the setup command.

Do you want to continue using this directory? [yes/no] yes

Enter password

Warning: This certificate has not been identified as trusted in the local trust store

--------------------------------------

[

[

... (remove some data)

]

...

]

--------------------------------------

Warning: This certificate could be compromised

... (remove some data)

Warning: This certificate has not been identified as trusted in the local trust store

--------------------------------------

[

... (remove some data)

--------------------------------------

Do you trust the certificate chain? [yes/no] yes

Error: Some required configuration is missing, corrupt, inaccessible, or insecure (access permissions are too liberal).

Resolve the problem and run setup.

Answers

  • Hi,

    It looks like a regular user does not have access to the required configuration directory... try entering the command like this and specifying the -dir location.

    ./emcli setup -url=https://nsn175-105.us.oracle.com:7803/em -username=MYUSERNAME -dir=/directory/for/my/logfiles -trustall


    where -dir is the path to a location for the regular user (MYUSERNAME) to write their log files, and -trustall accepts all certificates.


    With this command you are specifying where you want your log fils to be placed(i.e in a location that you have access to) and by specifying the -trustall tag, you are specifying the minimum level of security that you want your emcil to communicate with, to the OMS.


    Good Luck!

    Maureen

  • Hi user13475271,

    Can you please confirm if my recommendation on Oct 2nd fixed your problem?

    thanks!

    Maureen

  • Hello Maureen,

    Sorry I wasn't able to get back to you. Lots apologies!

    The problem we encountered was due to certification. The very first time we make the call using emcli, login as root user. The emcli setup created a certificate and stored on the local machine. When we change user and login as abc, then we call emcli setup. At that point, the certificate created by the root user is used to compare with the certificate generated by the abc user. Thus the error occurs.

    Since the very first time we login as a root user, the subsequent logins with root user there is no complain of errors, but there are errors with other users.

    What we did to overcome this problem? We removed the certificate created during the emcli setup call. Then login as a abc user. After that all the subsequent call emcli setup (as abc user) worked.

    Leo

  • Are you using same install dir between root and non-root user.

    Can you give following details.

    Full path where emcli is installed for both users.

    Also give output of following as both root and non-root users.

    env | grep EMCLI

    emcli status

    emcli setup

  • Yes, we are using the same install dir for all user. We have fixed the problem as stated earlier (sorry for the confusion).

This discussion has been closed.