Forum Stats

  • 3,839,759 Users
  • 2,262,532 Discussions
  • 7,901,052 Comments

Discussions

New revision for a metadata only content

hfolguera
hfolguera Member Posts: 16
edited Nov 7, 2013 9:24AM in WebCenter Content

Hi all,

I'm using Webcenter Content (UCM) 11.1.1.6 and client is using a kind of documents without file associated. It's working fine with the AllowPrimaryMetaFile=true and createPrimaryMetaFile=1 variables, but client needs to have revisions of this content. We can't just update the content because they want to have a new revision for every change.

The checkout option is enabled but, when we try to create the new version, the metadata-only checkbox is missing and form asks for primary file.

Could you help me?

Thanks in advance.

«1

Answers

  • hfolguera
    hfolguera Member Posts: 16

    Hi Jiri,

    I've followed this Kyle's post, but it doesn't talk about revisions...

    Rule is enabled for any form (Checkin, checkin similar, update, info...), and in the "Update with Check-In" option the checkbox appears, but it's missing when we create a new revision.

    Any clue? Thanks.

  • Have you also used primaryFile:rowStyle=display:none?<br/><br/>

    Since you already have a rule, how exactly is it defined and used? Where I'm aiming here is checking a new revision actually uses a profile, or standard check-in form where no rules are applied.

  • hfolguera
    hfolguera Member Posts: 16

    I have disabled this option for testing.

    It's using a dedicated profile with dedicated rules. In the CHECKIN_NEW_FORM the checkbox appears, and in the CHECKIN_SEL_FORM it doesn't; but the rule is enabled for both.

  • I was able to replicate your issue. If I am right, the caveat is not in the fact that CHECKIN_SEL_FORM does not understand the rule, but rather that no rule is used at all (it defaults to the standard check-in).

    What have I done?

    - I have created a simple rule where all the three keys were filled with values as advised.

    - The rule contained just the mandatory fields (security group, document type document title).

    - Then, I have created a profile consisting of this rule only (defined as Excluded non-rule fields). Note that in my system Profile Trigger Field uses a custom field called xProfile, which contains values from a table, so I had to add another record to that table ("HidePrimary").

    - Now, with this setup, if you check in a new item using the profile, the Primary File is hidden, but when you check out the item and try to check in a new revision (CHECKIN_SEL_FORM) it appears - no profile, but standard check in form is used.

    - Therefore, I have modified the rule to contain also xProfile field (InfoOnly) and I filled it with the default value "HidePrimary". This will force the system to use the HidePrimary profile even when a new revision is being checked in.

    - Finally, I verified that it really works.

  • hfolguera
    hfolguera Member Posts: 16

    Our goal is to make a second revision, but still without any file.

    Following your steps we are able to see the "Primary File" button in the CHECKIN_SEL_FORM...but what we want is to auto-create a new meta file for the second revision. This way, user shouldn't upload a file and a new revision would be in the revisions table.

    Is it possible?

    Thanks in advance.

  • I thought I showed the way - sorry, if it was not clear.

    The key point is that you need to include xProfile,or whichever field you use as the Profile Trigger Field, into your profile, and fill in its value via <$dprDefeaultValue$>. Like this it will be secured that even next time the profile is used, and you won't end up with the standard check-in form.

  • hfolguera
    hfolguera Member Posts: 16

    I didn't told you about the xIdcProfile, sorry...

    Yes, I already have the field in the rule as hidden and with a default value. So when I try to do the second checkin (after checkout) i'm redirected to CHECKIN_SEL_FORM and profile is triggered fine (the Full Check-in Form button appears, and if i click, xIdcProfile has inherited the correct value); but i'm still not able to see the "Metadata only" checkbox in the form.

    Hope that helps!

  • Well, the point is that you should not be redirected to Full Check-in form, but to the profile where your "Metadata only" rule is used.

    I'm sorry, but this is certainly a configuration issue - I was able to achieve the required. Unfortunately, without seeing the system I cannot tell what's wrong, but I'm sure there is a flaw somewhere.

  • hfolguera
    hfolguera Member Posts: 16

    OK, I'll open a SR.

    Thanks a lot for your help Jiri.

    best regards,

    hfolguera.

This discussion has been closed.