Forum Stats

  • 3,826,880 Users
  • 2,260,721 Discussions
  • 7,897,109 Comments

Discussions

Pages Access Setting in runtime back to the default value after redeployment

Rico
Rico Member Posts: 52
edited Nov 28, 2013 7:58AM in WebCenter Portal

Hi,


I'm developing Webcenter Portal - Framework Application using Oracle ADF.

At first, we already assign custom role/user to Pages Access in runtime Webcenter Portal Administration Console.

Then, after redeployment the Pages Access setting back to the default value.

Is there any way to make the configuration stay after redeployment?


Thanks,

ricky

Tagged:

Answers

  • Rico
    Rico Member Posts: 52

    hi Jiri,

    I have tried that method, but it didn't work.

    Actually the custom role that I assign to Page Access(page: User Guide) in runtime is 'ADM_PPO',

    but after redeployment the role for User Guide page is changed to user admin in webcenterportal ('66666').

    so it is not really setting back to the default value but changed to admin. 

    66666 is a user that has administrator role in our Portal.

    thanks,

    ricky

  • Daniel Merchán
    Daniel Merchán Enterprise Achitect Member Posts: 2,192 Gold Trophy

    Hi.

    When packaging the .EAR file you can select if bring or not the application policies and the credentials to be override.

    Go to Application Properties -> Deployment. In Security Deployment Options you can uncheck the options to prevent losing the changes after a re-deployment.

    Regards.

    Daniel Merchán
  • Rico
    Rico Member Posts: 52

    Hi Daniel,

    The problem is solved after i unchecked the Application Security in Security Deployment Options.

    But I realized something,

    1. It doesn't work if I do the redeployment after I delete the existing/previous deployment on the weblogic.

        go to Weblogic Console - Deployment -  delete the previous deployment, then do redeployment from JDev

    2. It works if I do the redeployment without deleting the existing/previous deployment

    Thanks anyway for the answer

    regards,

    ricky

This discussion has been closed.