apps-infra

    Forum Stats

  • 3,873,973 Users
  • 2,266,656 Discussions
  • 7,911,679 Comments

Discussions

OEID 2.3 Lexalytics java.lang.nosuchMethodError

1061360
1061360 Member Posts: 4
edited Dec 21, 2013 11:34PM in Endeca Information Discovery

Hi,

I am running OEID 2.3.0 using the WIndows installer and have installed Salience lexalytics on the same. It was working just fine till I did some changes to the JDK setups on the machine.

However now I have reverted the jdk back to JDL 7 but every time I try to run the graph on my local CLover ETL client, I am getting the following error:

INFO  [main] - Checking graph configuration...

INFO  [main] - Salience license: C:\lexalytics\textenrichsentiment51_perm_license.v5

INFO  [main] - Salience data dir: C:\lexalytics\survey_data

Exception in thread "main" java.lang.NoSuchMethodError: <init>

  at com.lexalytics.salience.Salience.initializeIds(Native Method)

  at com.lexalytics.salience.Salience.<clinit>(Salience.java:19)

  at com.endeca.clover.adapters.salience.SalienceComponent.init(SalienceComponent.java:442)

  at com.endeca.clover.adapters.salience.SalienceComponent.checkConfig(SalienceComponent.java:768)

  at org.jetel.graph.Phase.checkConfig(Phase.java:347)

  at org.jetel.graph.TransformationGraph.checkConfig(TransformationGraph.java:1113)

  at org.jetel.graph.runtime.EngineInitializer.initGraph(EngineInitializer.java:222)

  at org.jetel.graph.runtime.EngineInitializer.initGraph(EngineInitializer.java:202)

  at org.jetel.main.runGraph.runGraph(runGraph.java:364)

  at org.jetel.main.runGraph.main(runGraph.java:328)

Has anybody faced this issue before ? Any idea what could be causing it to no find the main class ? I tried digging in the code for Salience package as well but there is nothing in the method  initializeIDs()

Tagged:

Answers

  • 1061360
    1061360 Member Posts: 4

    I got it working, thanks to inputs from my colleagues

    The issue was that since I was trying to migrate to 3.1.0 from 2.3.0 on my local, it just messed up with the salience-api jar that was lying in the plugins directory of my Integrator client installation.

    Replacing the JAR file with the original, correct version and restarting LDI solved the issue for me.

This discussion has been closed.
apps-infra