Forum Stats

  • 3,814,892 Users
  • 2,258,925 Discussions
  • 7,892,883 Comments

Discussions

OEM agent install fails

Tom Lester-Oracle
Tom Lester-Oracle Member Posts: 21
edited Jul 10, 2014 1:07PM in Enterprise Manager

Hi all -

I'm having an issue with a dozen or so hosts.  I have a silent install that I have used to deploy to a couple thousand hosts with no problem.  Now...  I'm having trouble with these hosts.  I thought it was this:  MOS 1457347.1  and it might still be.  But, their resolution didn't help.   A couple of things to note... these are all hosts that have Oracle DB's already running on them.  Also..  there is not a /usr/lib/oracle directory.  When I try to run an emctl agent status after this runs, I get:


/home/oemagent/agent_inst/core/12.1.0.3.0/bin/emctl: line 457: /usr/lib/oracle/agent/core/12.1.0.3.0/perl/bin/perl: No such file or directory. 

When I try to run the solution in MOS 1457347.1, I get the same error for java (not found under /usr/lib/oracle/...).

It really feels like it has something to do with the oraInv.loc or something.  There is already an oraInventory in /u01/app/oraInventory.  I changed the permissions to 777 on this directory (not recursive) and that didn't help.  There IS a /etc/oraInst.loc file owned by root and 644. 

[[email protected] tmp]# cat /etc/oraInst.loc

inventory_loc=/u01/app/oraInventory

inst_group=oinstall

Any clues?  Any help is very appreciated.

-Tom

Unpacking software....

Archive:  em12c_agent.Linux.64.zip

  inflating: unzip                  

  inflating: agentDeploy.sh         

  inflating: agentimage.properties  

  inflating: agent.rsp              

extracting: agentcoreimage.zip     

extracting: 12.1.0.3.0_PluginsOneoffs_226.zip 

Validating the OMS_HOST & EM_UPLOAD_PORT

Executing command : /home/oemagent/agent_inst/core/12.1.0.3.0/jdk/bin/java -classpath /home/oemagent/agent_inst/core/12.1.0.3.0/jlib/agentInstaller.jar:/home/oemagent/agent_inst/core/12.1.0.3.0/oui/jlib/OraInstaller.jar oracle.sysman.agent.installer.AgentInstaller /home/oemagent/agent_inst/core/12.1.0.3.0 /tmp/oem_agent_tmp.114312 /home/oemagent/agent_inst -prereq

Inventory Location: /home/oemagent/agent_inst/oraInventory pointed by inventory pointer location: /home/oemagent/agent_inst/oraInst.loc does not exist.

Validating oms host & port with url: http://XXXXX.XXXXXX.net:4900/empbs/genwallet

Validating oms host & port with url: https://XXXXX.XXXXXX.net:4900/empbs/genwallet

Return status:3-oms https port is passed

Unzipping the agentcoreimage.zip to /home/oemagent/agent_inst ....

12.1.0.3.0_PluginsOneoffs_226.zip

Executing command : /tmp/oem_agent_tmp.114312/unzip -o /tmp/oem_agent_tmp.114312/12.1.0.3.0_PluginsOneoffs_226.zip -d /home/oemagent/agent_inst

Executing command : /home/oemagent/agent_inst/core/12.1.0.3.0/jdk/bin/java -classpath /home/oemagent/agent_inst/core/12.1.0.3.0/oui/jlib/OraInstaller.jar:/home/oemagent/agent_inst/core/12.1.0.3.0/oui/jlib/xmlparserv2.jar:/home/oemagent/agent_inst/core/12.1.0.3.0/oui/jlib/srvm.jar:/home/oemagent/agent_inst/core/12.1.0.3.0/oui/jlib/emCfg.jar:/home/oemagent/agent_inst/core/12.1.0.3.0/jlib/agentInstaller.jar:/home/oemagent/agent_inst/core/12.1.0.3.0/oui/jlib/share.jar oracle.sysman.agent.installer.AgentInstaller /home/oemagent/agent_inst/core/12.1.0.3.0 /tmp/oem_agent_tmp.114312 /home/oemagent/agent_inst /home/oemagent/agent_inst/agent_inst AGENT_BASE_DIR=/home/oemagent/agent_inst

Cloning the agent home...

Executing command: /home/oemagent/agent_inst/core/12.1.0.3.0/oui/bin/runInstaller -debug   -ignoreSysPrereqs -clone -forceClone -silent -waitForCompletion -nowait ORACLE_HOME=/home/oemagent/agent_inst/core/12.1.0.3.0   AGENT_BASE_DIR=/home/oemagent/agent_inst AGENT_BASE_DIR=/home/oemagent/agent_inst OMS_HOST=oms.tee.taleocloud.net AGENT_REGISTRATION_PASSWORD=p4aSa_s5 EM_UPLOAD_PORT=4900 AGENT_PORT=3872 b_startAgent=true -noconfig  ORACLE_HOME_NAME=agent12c1 -invPtrLoc /home/oemagent/agent_inst/oraInst.loc -force b_noUpgrade=true

Clone Action Logs Location:/home/oemagent/agent_inst/oraInventory/logs/cloneActions<timestamp>.log

Cloning of agent home completed successfully

Attaching sbin home...

Executing command: /home/oemagent/agent_inst/core/12.1.0.3.0/oui/bin/runInstaller -debug   -ignoreSysPrereqs -attachHome -waitForCompletion -nowait ORACLE_HOME=/home/oemagent/agent_inst/sbin ORACLE_HOME_NAME=sbin12c1 -invPtrLoc /home/oemagent/agent_inst/oraInst.loc -force

Attach Home Logs Location:/home/oemagent/agent_inst/core/12.1.0.3.0/cfgtoollogs/agentDeploy/AttachHome<timestamp>.log

Attach home for sbin home completed successfully.

Updating home dependencies...

Executing command: /home/oemagent/agent_inst/core/12.1.0.3.0/oui/bin/runInstaller -debug   -ignoreSysPrereqs -updateHomeDeps -waitForCompletion HOME_DEPENDENCY_LIST={/home/oemagent/agent_inst/sbin:/home/oemagent/agent_inst/core/12.1.0.3.0} -invPtrLoc /home/oemagent/agent_inst/core/12.1.0.3.0/oraInst.loc -force

Update Home Dependencies Location:/home/oemagent/agent_inst/core/12.1.0.3.0/cfgtoollogs/agentDeploy/UpdateHomeDeps<timestamp>.log

ERROR: Update home dependency failed.

Note:  This file doesn't exist:  /home/oemagent/agent_inst/core/12.1.0.3.0/cfgtoollogs/agentDeploy/UpdateHomeDeps<timestamp>.log

«1

Answers

  • mnazim-Oracle
    mnazim-Oracle Member Posts: 3,814

    This is because you passed wrong invPtrLoc, your inventory is under /u01/app/oraInventory but you are passing on other location.

    [email protected] tmp]# cat /etc/oraInst.loc 

    inventory_loc=/u01/app/oraInventory

    Inventory Location: /home/oemagent/agent_inst/oraInventory pointed by inventory pointer

    Please don't pass invPtrLoc and check. There is also a UI method to install agent at one shot on each hosts, might be you want to explore that one also,thus providing you a link to check:

    http://docs.oracle.com/cd/E24628_01/install.121/e22624/install_agent.htm#CACJEFJI

  • I tried both not passing the -invPrtLoc option AND passing the -invPrtLoc option, but pointing to the /etc/oraInst.loc file.  Neither worked.  Same issue.

  • mnazim-Oracle
    mnazim-Oracle Member Posts: 3,814

    Look like existing inventory has some problem.  Anyway try by passing INVENTORY_LOCATION=$HOME/oraInventory instead of  InvPtrLoc and check

  • EricvdS
    EricvdS Member Posts: 975 Bronze Trophy

    But did you create the /usr/lib/oracle directory? It is a prerequisite at least for silent agent installation.

    Ensure that the /usr/lib/oracle directory exists and has at least 2 GB of free space. If it does not exist, create it, and ensure that the install user has write permissions on it.

    Eric

  • I tried setting the INVENTORY_LOCATION.  same problem.

    Itried creating the /usr/lib/oracle directory (with more than 2GB of space), no luck.  Changed the perms to 777, still no luck. 

  • mnazim-Oracle
    mnazim-Oracle Member Posts: 3,814

    /usr/lib/oracle is required only for rpm agent install, how you are doing agent install, please provide the exact steps?

  • I have a script that I wrote that gathers architecture settings, grabs the appropriate OMA bundle, configures all the appropriate variables, then runs the agentDeploy.sh

    The agentDeploy.sh looks like this:

    su  $AGENT_USER -c "export TZ=UTC;$WDIR/agentDeploy.sh AGENT_BASE_DIR=$AGENT_BASE -invPtrLoc $AGENT_BASE/oraInst.loc OMS_HOST=$OMS_HOST AGENT_REGISTRATION_PASSWORD=$AGENT_REGISTRATION_PASSWORD EM_UPLOAD_PORT=$EM_UPLOAD_PORT AGENT_PORT=$AGENT_PORT -ignorePrereqs b_startAgent=true"

    Where the variables are supplied via the script.  Like I mentioned...   this has worked extremely well for 2000+ hosts.  There is something unique about these hosts that it causing it to fail. 

  • Ok...  I'm getting further down the rabbit hole.  I've discovered that some how, despite me declaring where the oraInst.loc is and what's populated in that file, during the execution of agentDeploy.sh, it's picking up that the inventory location is:

    /ade/aime1_vw/oracle/work/Shiphome/oraInventory

    This doesn't exist.  Where is it getting this info?  It must be an environment variable somewhere that I need to unset, but I have no idea what it is.

  • Courtney Llamas-Oracle
    Courtney Llamas-Oracle Member Posts: 782 Employee

    When you are running your script, it's calling -invPtrLoc $AGENT_BASE/oraInst.loc  which would be /home/.../oraInst.loc right?   You are trying to use the /etc/oraInst.loc pointer file though?  

    Is this Linux?

  • mnazim-Oracle
    mnazim-Oracle Member Posts: 3,814

    >I have a script that I wrote that gathers architecture settings, grabs the appropriate OMA bundle, configures all the appropriate variables, then runs the agentDeploy.sh

    How did you download OMA bundle, what are those env variable that you are setting and which log you see /ade/aime1_vw/oracle/work/Shiphome/oraInventory

    Can you provide full info?

This discussion has been closed.