Forum Stats

  • 3,826,928 Users
  • 2,260,726 Discussions
  • 7,897,123 Comments

Discussions

Cannot create ADF task flow from Human Task if SOA shared schema is imported

James.Tran
James.Tran Member Posts: 87

In my application, I am trying to implement a feature to allow initiating a BPMN process with attachments. To BPM beginners like me, manipulating arrays using XPath functions is quite complicated. Hence, to implement this feature, my strategy is to directly put attachments on the payload using the "attachmentType" in the SOA shared WorkflowTask.xsd schema. The goal is that when the payload arrives at the BPMN process, it'd be possible to directly map the submitted attachments from the payload into Tasks' "execData" as they're of the same "attachmentType".

In the XSD for my payload, I created an element using the "attachmentType" from the shared WorkflowTask.xsd.

<xsd:schema xmlns="http://www.w3.org/2001/XMLSchema"
            xmlns:ts="http://www.scm.com/test/xsd/testSchema"
            xmlns:oj="http://xmlns.oracle.com/bpel/workflow/task"
            targetNamespace="http://www.scm.com/test/xsd/testSchema"
            elementFormDefault="qualified">

  <xsd:import namespace="http://xmlns.oracle.com/bpel/workflow/task" 
              schemaLocation="oramds:/apps/shared/workflow/WorkflowTask.xsd"/>

  ...

  <xsd:element name="payloadInfo">
    <xsd:complexType>
      <xsd:sequence>
        <xsd:element name="attachment" type="oj:attachmentType" minOccurs="0" maxOccurs="unbounded"/>
      </xsd:sequence>
    </xsd:complexType>
  </xsd:element>

  ...
</xsd:schema>




However, based on this known issue - Importing Shared Schema from MDS Does Not Copy the Schema Imports, it seems like importing shared schema directly from the MDS does not work. As a consequence, even though JDeveloper does not show any errors for the above XSD, when I tried to create an ADF Task Flow from a Human Task that uses the above schema, JDeveloper couldn't generate anything. A new Data Control is generated in the Data Control Pallete but it is completely empty.

The workaround for the above issue is to "manually localize the schema". I don't really understand what it means but I tried to import the shared schema using normal file path as following.

<xsd:import namespace="http://xmlns.oracle.com/bpel/workflow/task" 
            schemaLocation="../../soa/shared/workflow/WorkflowTask.xsd"/>



However, this does not help at all. I still cannot create a Data Control for the Human Task.

If I remove everything related to the WorkflowTask.xsd, the Data Control will be generated properly.

I'd be very grateful if you could show me how I can properly import the SOA shared WorkflowTask.xsd file to make use of the attachmentType.

This discussion has been closed.