Forum Stats

  • 3,827,919 Users
  • 2,260,839 Discussions
  • 7,897,407 Comments

Discussions

ORA-29024: Certificate validation failure - https://accounts.google.com/o/oauth2/auth

Pete Town - Everest
Pete Town - Everest Member Posts: 3
edited May 11, 2015 4:43PM in Database Security - General

Dear All,

I've done a fair amount of digging and I've not found anything that can help me on this one.

I've setup a wallet on my database and imported the following certificates.

pastedImage_0.png

When I run:

SELECT utl_http.request('https://accounts.google.com/o/oauth2/auth',null,'file:C:\OracleDatabase\product\12.1.0\dbhome_1\owm\wallets\oracle','superman99') from dual;

I get:

ORA-29273: HTTP request failed

ORA-29024: Certificate validation failure

ORA-06512: at "SYS.UTL_HTTP", line 1491

ORA-06512: at line 1

Running it for https://google.com is successful. even running it for https://maps.google.com is successful.

Doing for further digging around I notice that there is a call to the following:

pastedImage_1.png

Naviaging to this i find a *.google.com certificate:

pastedImage_3.png

I've tried exporting and loading this certficate several times in severeal ways and in different formats but I always get the same exception:

pastedImage_4.png

I have tried removing all certificates except this one and I still get the same error.

My Oracle version is:12.1.0.2.0 Enterprise Edition

On: Microsoft Windows x86 64-bit

Update I found the following article, and I've tried removing the endpoint URL SSL certificate, but sadly it's still not working:

Thanks for your help!

Peter

Tagged:

Answers

This discussion has been closed.