Forum Stats

  • 3,853,736 Users
  • 2,264,259 Discussions
  • 7,905,437 Comments

Discussions

change the default sender email - email notifications

2940488
2940488 Member Posts: 27
edited Dec 16, 2015 5:24PM in Identity Manager

I am implementing the email notifications with the standard OIM templates(11gr2ps2). I have configured the Email Server IT Resource and the emails are being sent from "[email protected]" and I read in one of the previous discussions which said that is the standard email address.

Is there a way I can change to the From address that I want? or do I need to write a custom email program for this. I will be using the locale templates, so it would be easier if I can just change the From address, if not I will write a custom program.

Thanks.

Tagged:
Amy Childress-Oracle

Best Answer

Answers

  • Kevin Pinsky
    Kevin Pinsky Member Posts: 5,322 Silver Crown
    edited Dec 14, 2015 4:18PM

    Two places to check.  The email address of your XELSYSADM user and the email driver properties in your enterprise manager.

    -Kevin

  • 2940488
    2940488 Member Posts: 27
    edited Dec 14, 2015 5:03PM

    Thanks. I tried to update the email address of XELSYSADM directly in the USR table in OIM DB, but it did not help.

    I tried to find the email driver properties, but I do not have the "usermessagingdriver" property in enterprise manager. I only have the following in the top hirearchy

    • Application Deployments
    • WebLogic Domain
    • Identity and Access
    • Metadata Repositories

    Please let me know if I am missing anything. Thanks.

  • Nirupam Samanta
    Nirupam Samanta Member Posts: 421
    edited Dec 15, 2015 12:39AM

    It should work if u change the email id of xelsysadm. I did that from console and it was working.

    Amy Childress-Oracle
  • 2940488
    2940488 Member Posts: 27
    edited Dec 15, 2015 10:21AM

    Thanks, when I tried to update the xelsysadm via UI, I got this error

    <BEA-000000> <

    oracle.bpel.services.workflow.client.WorkflowServiceClientException: javax.naming.CommunicationException [Root exception is java.net.ConnectException: t3://serverIP:8001: Destination unreachable.

    I am not sure why OIM is trying to connect to 8001 port, so I restarted the server and got the same error.

    Had this error when the oim server was starting

    For more information please enable logging for oracle.adf.share.ADFContext at FINEST level.>

    TaskFlow Registration: IntegratwTaskFlowWithTask.registerTaskFlowWithTask - beginTaskFlow Registration: IntegratwTaskFlowWithTask.registerTaskFlowWithTask - hwtaskflow.xml         url is: zip:/folder/base_domain/servers/oim_server1/tmp/_WL_user/oracle.iam.console.identity.self-service.ear_V2.0/ymucpj/war/WEB-INF/lib/_wl_cls_gen.jar!/hwtaskflow.xmlTaskFlow Registration: IntegratwTaskFlowWithTask.registerTaskFlowWithTask - Reading hwtaskflow.xmlTaskFlow Registration: IntegratwTaskFlowWithTask.registerTaskFlowWithTask - applicationName is worklistTaskFlow Registration: IntegratwTaskFlowWithTask.registerTaskFlowWithTask - deployed attribute value is falseTaskFlow Registration: IntegratwTaskFlowWithTask.registerTaskFlowWithTask - http info is serverIP, 14000, 0, TaskFlow Registration: IntegratwTaskFlowWithTask.registerTaskFlowWithTask - end

    <Dec 15, 2015 10:02:39 AM EST> <Error> <oracle.iam> <BEA-000000> <Error processing Default User Views javax.naming.CommunicationException [Root exception is java.net.ConnectException: t3://serverIP:8001: Destination unreachable; nested exception is:

            java.net.ConnectException: Connection refused; No available router to destination]>

    <Dec 15, 2015 10:02:46 AM EST> <Warning> <oracle.adfinternal.view.faces.partition.FeatureUtils> <ADF_FACES-30130> <Ignoring feature-dependency on feature "AdfDvtCommon".  No such feature exists.>

    <Dec 15, 2015 10:02:51 AM EST> <Notice> <Log Management> <BEA-170027> <The Server has established connection with the Domain level Diagnostic Service successfully.>

    <Dec 15, 2015 10:02:51 AM EST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to ADMIN>

    <Dec 15, 2015 10:02:51 AM EST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RESUMING>

    I used the following command to start the oim server

    ./startManagedWebLogic.sh oim_server1 > folder/servers/oim_server1/logs/oim_server1_1.out 2>&1 &

    Thanks.

  • Abhishek Singh 'J_IDM'
    Abhishek Singh 'J_IDM' Member Posts: 2,448 Gold Trophy
    edited Dec 15, 2015 10:47AM Answer ✓

    Looks like your SOA server is down. Start SOA server and try again.

  • Amy Childress-Oracle
    Amy Childress-Oracle Member Posts: 93 Employee
    edited Dec 15, 2015 12:33PM

    Hello 2940488,

    The OIM server shouldn't be trying to access SOA using an address like "serverIP:8001" .  To me, this indicates an issue in your configuration.

    Check your RmiURL (login to Enterprise Manager (EM) -> Navigate to weblogic domain -> Right click and select System MBean Browser -> Under Application Defined MBeans, expand oracle.iam -> oim_server1 -> oim -> XMLConfig - > Config -> XMLConfig.SOAConfig -> SOAConfig), the SOA cluster address (or the SOA managed servers' listen port and address if a single node) and the ForeignJNDIProvider-SOA Provider-url.  The values for the ForeignJNDIProvider-SOA provider-url and SOA cluster address (or the SOA managed servers' listen port and address if a single node) are accessed through the WLS Console.  These should all match and be using the same protocol.

    For example:

    • If you have SSL configured for the SOA managed servers - then make sure that the RmiUrl and ForeignJNDIProvider-SOA provider-url are using the  t3s:// protocol setting.  If SSL is not configured, then make sure that you have the RmiUrl and ForeignJNDIProvider-SOA provider-url set with t3:// protocol setting.
    • If you have a list of managed servers for the SOA cluster address, then the RmiUrl and ForeignJNDIProvider-SOA provider-url values should have those same servers.  If you don't have a cluster, this will just be your SOA managed servers' listen address and port.

    The values in the the RmiURL and ForeignJNDIProvider-SOA provider-url  should be a comma separated list of the SOA managed server listening addresses (including the ports) preceded by the SSL specific t3 protocol -like:

          t3://soahost1:8001,soahost2:8001  - Where soahost1 is the listen address for the 1st managed server and the listening port is 8001 (ie..non SSL 2 node cluster).

         OR

         t3s//soahost1:8002,soahost2:8002  - Where soahost1 is the listen address for the 1st managed server and the listening port is 8002 (ie. SSL enabled 2 node cluster).


    Hope that helps,

    Amy

    -----

    When closing a thread as answered remember to mark the correct and helpful posts to make it easier for others to find them.

    2940488
  • 2940488
    2940488 Member Posts: 27
    edited Dec 15, 2015 4:37PM

    Thanks Amy and Abhishek.

    We have installed SOA, but we do not need SOA in our implementation, so we usually do not start that server. We do not have any workflow approvals. Would not starting SOA server be an issue?

    Thanks again.

  • Kevin Pinsky
    Kevin Pinsky Member Posts: 5,322 Silver Crown
    edited Dec 16, 2015 5:37AM

    The SOA server is part of the product successfully running. It needs to be up.

    To add to this, I did see there is an option in ps3 to disable workflows and soa but there is no going back once you do that.

    http://docs.oracle.com/cd/E52734_01/oim/OMADM/workflowrules.htm#OMADM5644

    -Kevin

    Amy Childress-Oracle
  • 2940488
    2940488 Member Posts: 27
    edited Dec 16, 2015 5:24PM
This discussion has been closed.