Forum Stats

  • 3,815,637 Users
  • 2,259,064 Discussions
  • 7,893,194 Comments

Discussions

SUNWfanctl error

ODesk
ODesk Member Posts: 27 Blue Ribbon

Installing SUNWfanctl as per Doc ID 1548649.1 to resolve Bug 15403228

After the package is installed, the service does not start and goes to maintenance.  Running the binary manually shows the error:


#/opt/SUNWfanctl/bin/fanctld
Cannot open debug port
: No such file or directory

System Is Ultra 45 with motherboard P/N 375-3278 and Solaris 10 u11

Any thoughts?  I suspect the binary is only tested to u3 release, but don't have a current maintenance agreement to get further support (which reminds me, I must rectify that too!)

Best Answer

  • ODesk
    ODesk Member Posts: 27 Blue Ribbon
    edited Feb 17, 2016 6:37PM Answer ✓

    I had a think about it, and the error "cannot open debug port" suggested maybe it was trying to find a hardware device controlled by the jumper pins, and "No such file or directory" perhaps meant an issue in /dev.

    So I rebuilt the device tree using "boot -F failsafe" and some guidance from Repairing the Solaris /dev and /devices directories

    The binary now runs, but whether it solves the bug for me remains to be seen

Answers

  • ODesk
    ODesk Member Posts: 27 Blue Ribbon
    edited Feb 17, 2016 6:37PM Answer ✓

    I had a think about it, and the error "cannot open debug port" suggested maybe it was trying to find a hardware device controlled by the jumper pins, and "No such file or directory" perhaps meant an issue in /dev.

    So I rebuilt the device tree using "boot -F failsafe" and some guidance from Repairing the Solaris /dev and /devices directories

    The binary now runs, but whether it solves the bug for me remains to be seen

This discussion has been closed.