Forum Stats

  • 3,826,228 Users
  • 2,260,609 Discussions


Unable to recreate Management Repository

fletch_lindo Member Posts: 4
edited May 10, 2016 9:15PM in Enterprise Manager

I'm beginer of Oracle, I'm setting up Oracle DB and Enterprise Manager.
After installation of Enterprise Manager, I could not start dbconsole.

I tried to re-setup Oracle Management Repository following Link.
I could drop the Management Repository, But I couldn't recreate Management Repository.

.\repmanager <host> 1521 <SID> -sys_password <pass> -action create
[Error message]
Password entered for sysman did not match.Try agein..

I researched and found sysman account did not exist in DBA_USERS.
Before dropping the Management Repository, I could log in EM using sysman.

Please tell me how to recreate OMR,
can I change another account instead of sysman,
or can I create sysman account by command or another method.

[Documentation and Link]
15.3.1 Dropping the Management Repository
15.3.2 Recreating the Management Repository

Windows Server 2012 Standard
Enterprise Manager Cloud Control 12c R5


Best Answer


  • Hajime Obata-Oracle
    Hajime Obata-Oracle Member Posts: 67
    edited Mar 15, 2016 2:54AM

    Is it Enterprise Manager Cloud Control or Enterprise Manager Database Control that you want to drop/recreate Management Repository for?

    In case of Enterprise Manager Cloud Control, you have to completely reinstall Enterprise Manager Cloud Control to recreate Management Repository, as stated in the documentation that you referred:

    In the event a repository is dropped, you cannot create the repository alone using the "RepManager create" command. The command will not create all the required users in the repository database. To create the repository you must completely reinstall Cloud Control.

    If it is Enterprise Manager Database Control, the you have to use emca to drop/recreate it.

    By the way, you can have either one of the above in a database, not both. Once you get Cloud Control Management Repository configured in a database, you can't configure Database Control there.

    You can only use sysman as the repository owner.

  • fletch_lindo
    fletch_lindo Member Posts: 4
    edited Mar 15, 2016 3:44AM

    Hi, Hobata-Oracle, Thank you for your reply.

    I misunderstood all the Enterprise Manager on and after 12c is cloud control.
    Now I have no plan to use cloud control.
    So I tried your advice following the link.

    To my regret, I could not use emca.
    At my environment, there is an emca.bat at oracle database directory.
    so I execute the following.Do you know whether there is mistake ? I would like to know solution procedure.

    cd <ora_home>\bin
    .\emca -deconfig dbcontrol db

    [Error Message]
    Invalid syntax

  • Loc Nhan-Oracle
    Loc Nhan-Oracle Member Posts: 770 Employee
    edited Mar 15, 2016 12:56PM Answer ✓

    What is the version of your database? Database control is no longer available in database 12c. If this is a 12c database, use Enterprise Manager Database Express instead. EM Database Express is built inside a database 12c.

    See the doc below for information on EM Database Express.


    - Loc

  • fletch_lindo
    fletch_lindo Member Posts: 4
    edited Mar 17, 2016 3:12AM

    Hi, Loc Nhan-Oracle. Thank you for your reply.

    I use the following database. I didn't know that Database control is no longer available in database 12c.

    I checked your information about EM Express , Upgrade Guide about 12c and how my EM Express was set.

    To my regret, EM Express doesn't work now.

    I could not access the URL of EM Express.

    The description about "local_listener" isn't written in "init.ora".

    From now , I will try to set EM Express.


    Oracle Database 12c  Enterprise Edition Release  64bit Production

    Database and Enterprise Manager Cloud Control are installed in the same server.

  • fletch_lindo
    fletch_lindo Member Posts: 4
    edited May 10, 2016 9:15PM

    Thank you, Loc Nhan-Oracle.

    Your suggestion is correct.

    I set up EM Express. But I cannot do what I want to do next.

    So I will reinstall EM 12c again as Hobota-Oracle advised.

This discussion has been closed.