Forum Stats

  • 3,780,576 Users
  • 2,254,410 Discussions
  • 7,879,386 Comments

Discussions

ADF version on Java Cloud Service-SaaS Extension

user10739353
user10739353 Member Posts: 20
edited Jul 26, 2016 11:11AM in Java Cloud Service

What is the ADF version on current available JCS-SaaS extension that is publicly available through trial/ as a metered version?

Actually came across latest version of Oracle Rapid Development Kit for developing PaaS for SaaS solutions on JCS-SX. However it states that for compiling the libraries that comes with RDK will require a minimum ADF version of 11.1.1.9.0[http://www.oracle.com/webfolder/ux/applications/successStories/pdf/RDKDeveBookR10.pdf].

So is the current JCS-SX on ADF 11.1.1.9.0. We need this information urgently for one of our customers who will be procuring JCS-SX.

Thanks

Mandrita

ShaikFicus

Answers

  • Manish Kapur-Oracle
    Manish Kapur-Oracle Member Posts: 73 Employee
    edited Jun 23, 2016 3:28PM

    I believe the current version of ADF in JCS SaaS extension is 11.1.1.7.1. Docs reference here.

    This may change soon though when JCS SaaS extension moves to a newer version.

  • ShaikFicus
    ShaikFicus Member Posts: 4
    edited Jul 25, 2016 9:03AM

    Can we use R10 Cloud UI RDK for Deploying into the JCS-SX by using JDEV 11.1.1.9? When we tried, Deployment is failing.

    Is R10 is compatible with JCS-SX?

    below is the error

    weblogic.utils.compiler.ToolFailureException: jspc failed with errors :weblogic.servlet.jsp.CompilationException: Announcements.jsff:11:4: This tag is not recognized.

      <af:deck id="d1" styleClass="announcements-grid-mode-size"

       ^-----^

    Announcements.jsff:11:4: This tag is not recognized.

      <af:deck id="d1" styleClass="announcements-grid-mode-size"

       ^-----^

    Announcements.jsff:14:6: This tag is not recognized.

        <af:transition transition="flipStart" triggerType="forwardNavigate"/>

         ^-----------^

    Announcements.jsff:14:6: This tag is not recognized.

        <af:transition transition="flipStart" triggerType="forwardNavigate"/>

         ^-----------^

    Announcements.jsff:15:6: This tag is not recognized.

        <af:transition triggerType="backNavigate" transition="flipEnd"/>

         ^-----------^

    Announcements.jsff:15:6: This tag is not recognized.

        <af:transition triggerType="backNavigate" transition="flipEnd"/>

         ^-----------^

    Welcome.jspx:97:20: This tag is not recognized.

                      <af:deck id="homeDeck"

                       ^-----^

    Welcome.jspx:97:20: This tag is not recognized.

                      <af:deck id="homeDeck"

                       ^-----^

    Welcome.jspx:100:22: This tag is not recognized.

                        <af:transition transition="slideStart"

                         ^-----------^

    Welcome.jspx:100:22: This tag is not recognized.

                        <af:transition transition="slideStart"

                         ^-----------^

    Welcome.jspx:102:22: This tag is not recognized.

                        <af:transition triggerType="backNavigate"

                         ^-----------^

    Welcome.jspx:102:22: This tag is not recognized.

                        <af:transition triggerType="backNavigate"

                         ^-----------^

        at weblogic.servlet.jsp.jspc20.runBodyInternal(jspc20.java:460)

        at weblogic.servlet.jsp.jspc20.runJspc(jspc20.java:228)

        at weblogic.servlet.jsp.JspcInvoker.compile(JspcInvoker.java:236)

        at weblogic.application.compiler.AppcUtils.compileWAR(AppcUtils.java:376)

        at weblogic.application.compiler.WARModule.compile(WARModule.java:245)

        at weblogic.application.compiler.flow.CompileModuleFlow.compileModules(CompileModuleFlow.java:103)

        at weblogic.application.compiler.flow.CompileModuleFlow.compile(CompileModuleFlow.java:51)

        at weblogic.application.compiler.FlowDriver$FlowStateChange.next(FlowDriver.java:69)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.compiler.FlowDriver.nextState(FlowDriver.java:36)

        at weblogic.application.compiler.FlowDriver.run(FlowDriver.java:26)

        at weblogic.application.compiler.EARCompiler.compile(EARCompiler.java:51)

        at weblogic.application.compiler.flow.AppCompilerFlow.compileInput(AppCompilerFlow.java:112)

        at weblogic.application.compiler.flow.AppCompilerFlow.compile(AppCompilerFlow.java:37)

        at weblogic.application.compiler.FlowDriver$FlowStateChange.next(FlowDriver.java:69)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.compiler.FlowDriver.nextState(FlowDriver.java:36)

        at weblogic.application.compiler.FlowDriver.run(FlowDriver.java:26)

        at weblogic.application.compiler.Appc.runBody(Appc.java:203)

        at weblogic.utils.compiler.Tool.run(Tool.java:158)

        at weblogic.utils.compiler.Tool.run(Tool.java:115)

        at weblogic.application.compiler.Appc.main(Appc.java:262)

        at weblogic.appc.main(appc.java:14)

  • Sudheerkumarvangala
    Sudheerkumarvangala Member Posts: 235 Blue Ribbon
    edited Jul 26, 2016 11:11AM

    I think Cloud UI RDK are compatible with JDeveloper & ADF 11.1.1.9.0 or upwards. Please refer to the thread below.

    Jdeveloper 11.1.1.7.1 Cloud Version

    However, I think for deploying your custom extensions for JCS-SX you need 11.1.1.7. On the Jdev download page it's recommended 11.1.1.7. Oracle JDeveloper Software

This discussion has been closed.