Forum Stats

  • 3,814,253 Users
  • 2,258,850 Discussions
  • 7,892,637 Comments

Discussions

Discoverer 10g with Java8

jffr363
jffr363 Member Posts: 13
edited Nov 22, 2016 11:58AM in Discoverer

Hello,

So we are running Discoverer 10g for a few users, and have many projects in place, and so an upgrade to Discoverer 11g is not a priority at this time. We are currently doing a migration to IE11 and Java8. Is there a workaround to get Discoverer 10g working with Java8 or is our only option to stay on java6 or upgrade to 11g?

Answers

  • sbeck-Oracle
    sbeck-Oracle Member Posts: 116 Employee
    edited Aug 12, 2016 12:42PM

    Discoverer 10g is not certified for use with Java 7 or Java 8.  Discoverer 11.1.1.7.0's use of Java 8 is only certified with an E-Business Suite (EBS) end user layer.  This certification requires a patch applied to 11.1.1.7.0. 
      Note 233047.1  (How To Find Oracle BI Discoverer 10g and 11g Certification Information) contains Frequently Asked Questions on certification.

  • Michael Armstrong-Smith
    Michael Armstrong-Smith Member Posts: 4,403
    edited Sep 6, 2016 12:49AM

    You would have to upgrade the Discoverer Java on the server if you want this to work. The server is typically installed with Java 6 which is not really compatible with a local Java 8

    If this doesn't work then you need to keep Java 6 locally just for Discoverer. You can have both Java 8 and Java 6 installed at the same time and tell Discoverer that it has to use 6

  • P Suresh
    P Suresh Member Posts: 63 Blue Ribbon
    edited Nov 22, 2016 11:58AM

    Hi jffr363,

    Not sure this patch (patch 20219002) will be useful for the 10g. But i suggest, upgrading to 11g and install the patch. The discoverer will be able to work with all versions of Java from (Java 6 to Java 8 ) without any issues. Make sure you add the url in the Java exception list of the client machine.

    Thanks,

    Suresh

This discussion has been closed.