Forum Stats

  • 3,734,836 Users
  • 2,247,053 Discussions
  • 7,857,516 Comments

Discussions

Illegal block type due to network error 32 ?

JanGLi
JanGLi Member Posts: 649 Bronze Badge
edited Jan 23, 2017 9:04AM in Planning and Budgeting

hi,

i was executing a business rule from a data form and i get this error "Network error [32]: Failed to send data"

After a while when my network was stable i tried again and this time i got this error "Invalid block header: Illegal block type -- Please restore from backup".

The question is....

1 - could network error corrupt my essbase?

Plus

2 - can i fix my illegal block size or only restoring data is the only remaining option.


regards

Tagged:

Answers

  • USER1211
    USER1211 Member Posts: 3,104
    edited Dec 23, 2016 8:02AM

    You did not specify the version of Hyperion(including patch level) you are on.

    Notably this topic has been raised on the forum before. You need to review your environment and see what is going on as of course only you know your environment and what processes exist on it not folks on the board

    The below document should help:

    Essbase v11.1.2+ Database Corruption/Invalid Block Header (IBH)) Error "Invalid transaction status for block -- Please use the IBH Locate/Fix utilities to find/fix the problem" (Doc ID 1679625.1)

    Good Luck and let us know how you make out.

  • JohnGoodwin
    JohnGoodwin Member Posts: 30,471 Blue Diamond
    edited Dec 23, 2016 8:30AM

    Similar IBH post from last week which also suggests the same support doc to review -

    Cheers

    John

  • JanGLi
    JanGLi Member Posts: 649 Bronze Badge
    edited Dec 23, 2016 9:02AM

    Thanks for help.

    Actually my main concern was, did my network cause the IBH? or was it already there?


    I did took application backup using LCM shared services. It was successful. Which suggest that there isn't any IBH.

    But from this thread it looks like the IBH was already there.


    Regards

  • JanGLi
    JanGLi Member Posts: 649 Bronze Badge
    edited Dec 23, 2016 9:04AM

    My essbase log from that time duration:

    "Fri Dec 23 17:12:33 2016]Local/HypUAT1/Plan1/[email protected] Directory/140735948318464/Info(1012668)

    Calculating [ Asset Class(Purchases of Stores and Spares,Purchases of Chemicals)] with fixed members [Account(51010001, 51010002, 51010003, 51010004, 51010005, 51010006, 51010007, 51010008, 51010009, 51010011, 51010012, 51015001, 51015002, 51015003, 51015010, 51025002, 51025001, 51025003, 51025004, ]

    [Fri Dec 23 17:12:33 2016]Local/HypUAT1/Plan1/[email protected] Directory/140735948318464/Info(1012677)

    Calculating in serial

    [Fri Dec 23 17:12:33 2016]Local/HypUAT1///140735948318464/Info(1008108)

    Essbase Internal Logic Error [7802]

    [Fri Dec 23 17:12:33 2016]Local/HypUAT1///140735948318464/Info(1008106)

    Exception error log [/u01/hyperion/application/user_projects/epmsystem1/diagnostics/logs/essbase/essbase/app/HypUAT1/log00015.xcp] is being created...

    [Fri Dec 23 17:12:33 2016]Local/HypUAT1///140735948318464/Info(1008153)

    A core file may get generated in []

    [Fri Dec 23 17:12:33 2016]Local/HypUAT1///140735948318464/Info(1008107)

    Exception error log completed /u01/hyperion/application/user_projects/epmsystem1/diagnostics/logs/essbase/essbase/app/HypUAT1/log00015.xcp please contact technical support and provide them with this file

    [Fri Dec 23 17:12:33 2016]Local/HypUAT1///140735948318464/Info(1002089)

    RECEIVED ABNORMAL SHUTDOWN COMMAND - APPLICATION TERMINATING

    [Fri Dec 23 17:13:08 2016]Local/HypUAT1///140737284589376/Info(1002139)

    Essbase Server 64-bit  - Release 11.1.2 (ESB11.1.2.4.000B193)

    [Fri Dec 23 17:13:08 2016]Local/HypUAT1///140737284589376/Info(1002035)

    Starting Essbase Server - Application [HypUAT1]"


    Regards

  • JohnGoodwin
    JohnGoodwin Member Posts: 30,471 Blue Diamond
    edited Dec 23, 2016 9:52AM

    That looks like the application log not essbase, anyway the log is just showing that it probably hit a corrupted block or it occurred when running a calc, there are suggestions of how and why it may have happened in the provided support doc.

    If you need to progress it further then it is Oracle you will need to talk to.

  • JanGLi
    JanGLi Member Posts: 649 Bronze Badge
    edited Jan 23, 2017 8:56AM

    Dear Guys,


    Sorry was for late reply.

    Yes the logs was of Application.

    I am still getting the same issue even after i have cleared my database.

    These are things which i have performed:

    1 - After i get the first illegal block header error. I cleared the database using eas console.

    2 - restored previous backup.

    3 - refreshed database to check it's integrity. It was ok.

    4 - exported data using eas console to check it's integrity. It was ok.

    5 - took application backup using shared services to check it's integrity. It was ok.

    6 - applied latest essbase, provider services, eas console and essbase studio patches.

    7 - Everything was working fine, but all of a sudden after couple of days passed i tried refreshing database and it took 40 mins (it shouldn't have taken longer than 1 min) and then error-red out.

    8 - Again the error was network error.

    I just have one questions:

    When we install EPM system and start services... connection with a network is compulsory. If my system isn't connected to the network, my services won't start (kindly correct me if i am wrong).

    Could network issue be caused because my server get disconnected from the network (the system get stand alone with ip as localhost/127.0.0.1), and the planning and essbase can't communicate? thus causing illegal headers blocks while it is refreshing database.

    Regards

  • JohnGoodwin
    JohnGoodwin Member Posts: 30,471 Blue Diamond
    edited Jan 23, 2017 9:04AM

    I take it you are talking about a personal install because I would be concerned about a server being disconnected from the network,

    The reasons why IBH errors occur are detailed in Doc ID 1679625.1 so maybe it is related to one of the reasons in the doc.

This discussion has been closed.