Forum Stats

  • 3,855,522 Users
  • 2,264,515 Discussions
  • 7,906,030 Comments

Discussions

Discoverer error after installing Java 8

drussosubaru
drussosubaru Member Posts: 5
edited Feb 7, 2017 3:37PM in Discoverer

Hello,

We are upgrading to EBS 12.2.6 and installed the required Java 8 version (1.8.0_111).  We are in the process of testing the EBS upgrade and still need to run both 12.1.3 and 12.2.6 on my client machine.  After installing Java 8 my 11g version of Discoverer is not working properly.  I currently have three versions of JRE installed (11.8.0_111, 1.6.0_31, and 1.6.0_27).  I'm getting the following error when launching Discoverer 11g:

"unable to connect to the discoverer server. null Please contact your Oracle Application Server Administrator"

Has anyone ever come across this error & have a solution to resolve?  Can I force a specific java version from the URL used to launch the app?

Thanks!

Answers

  • sbeck-Oracle
    sbeck-Oracle Member Posts: 116 Employee
    edited Feb 7, 2017 3:37PM

    Premier support for Discoverer 11g ended June 2014.  Version 11.1.1.7.0 is the final / terminal release of the Discoverer product.  Premier support is the only level of support that includes new releases and new certifications.  Therefore, any software update (Java, Browser, OS, EBS, etc.) released after June 2014 has not been specifically certified or tested.

    Discoverer 11.1.1.7.0 is only certified to use Java 8 when connecting to EBS and with Patch 20219002 applied.  If you do not have Patch 20219002 applied yet, please apply merge patch 22627325, which contains this patch and other java fixes.  Discoverer 11.1.1.7.0 was certified against 1.8.0_25, so the issue may be the Update level of Java 8.  Each Java update is tighter and tighter.  Eventually you may hit an update level that causes Plus to not work.  Try a lower java update version.

This discussion has been closed.