Forum Stats

  • 3,838,803 Users
  • 2,262,400 Discussions
  • 7,900,759 Comments

Discussions

Performance Issue on HFM Data Grid (After upgraded to 11.1.2.4.203)

Kris Chow-Oracle
Kris Chow-Oracle Member Posts: 27
edited May 25, 2017 10:07AM in Financial Consolidation

Hi Folks,

Customer is having a performance issue on data grid (right click on account and select entity detail) in the HFM version 11.1.2.4.203.

For some accounts member, it takes more than 30 minutes in order to retrieve all the entity detail.

But before the upgrade (HFM 11.1.1.3), customer can have the result in less than 5 minutes. Data volume should be roughly the same before and after the upgrade. Most of the HFM application configurations are using the default settings.

I know there had been a lot of code level changes between these 2 versions. Is this a product issue or something that can be configurable?

Anything could account for this degradation in the performance?

Upgrade Path:

11.1.1.3 -> 11.1.1.4 -> 11.1.2.3 -> 11.1.2.4 -> 11.1.2.4.203

Regards,

Kris

Answers

  • Vikram VK
    Vikram VK Member Posts: 1,204
    edited May 24, 2017 10:35AM

    Hi,

    -Have you tried in Mozilla Firefox Browser?

    -What if when you do the same POV setup in the SmartView, does it takes same time?

    -Is all the users are facing the same issue?

    -When it takes more time to open, at the same time have you got chance to check Processes/Memory via Task Manager in the HFM Server (just to make sure enough memory is available to execute the query)

    Thanks.

  • Thanos A
    Thanos A Consolidation System Manager Member Posts: 1,443 Silver Trophy
    edited May 24, 2017 1:42PM

    Any change in HS.Dynamic rules?

    Cheers,

    Thanos

  • Kris Chow-Oracle
    Kris Chow-Oracle Member Posts: 27
    edited May 24, 2017 10:15PM

    -Have you tried in Mozilla Firefox Browser?

    => Same issue

    -What if when you do the same POV setup in the SmartView, does it takes same time?

    => Same result

    -Is all the users are facing the same issue?

    => Test result is based on admin account

    -When it takes more time to open, at the same time have you got chance to check Processes/Memory via Task Manager in the HFM Server (just to make sure enough memory is available to execute the query)

    => 2 node active-active HFM cluster, about 50% memory usage. There should be enough memory on the machines.

  • ChrisTurnbull
    ChrisTurnbull Member Posts: 29
    edited May 24, 2017 10:45PM

    I don't think there will be any magic answer on here for this given you get the same timing on a Smart View Query, however we were on a similar upgrade path and had performance issues on 11.1.2 4 originally with Smart View retrievals. Obviously there could be a tonne of variables, but ours was rectified through a combination of Oracle recommended Tuning settings, Indexing and an increase in the IO speed on the Disk on the DB. Now our performance far exceeds what we had originally.

    Hope that helps. Good luck with your testing.

  • DeepFinder
    DeepFinder Member Posts: 349 Blue Ribbon
    edited May 25, 2017 5:23AM

    Hi Krish,

    We had faced some performance issue after we patched our HFM.

    We did gather stat and index rebuilding for HFM schema and the performance got enhanced.

    Check with your DBA and give a try after taking a DB back up.

  • Vikram VK
    Vikram VK Member Posts: 1,204
    edited May 25, 2017 10:07AM

    Well, I see that you have got handful suggestion/recommendation from @ChrisTurnbull and @DeepFinder

    It would be worth trying all those and keep us updated.

    All the best!

    Thanks.

This discussion has been closed.