Forum Stats

  • 3,840,337 Users
  • 2,262,589 Discussions
  • 7,901,227 Comments

Discussions

Oracle Opscenter 12c version12.3.3.0.0 (b1801) BBDD embeded empty library

User_W0UJD
User_W0UJD Member Posts: 4 Blue Ribbon
edited May 9, 2018 5:14AM in Enterprise Manager Ops Center

Hi,

Can someone help us, we installed Oracle OpsCenter with an embeded database:

(Oracle Solaris 11.3.27.4.0)

/opt/SUNWxvmoc/bin/ecadm -V

12.3.3.1801.

For a reason when we check the Linux, Solaris 8-10 Software Library, nothing appears into Distribution field,

actually at least 3 Distributions should appears:

Solaris10_Sparc

Solaris9_Sparc

Solarais10_X86

as configured in others opscenter's we have, but without embeded DB.

We even try to copy contents of another opscenter that Works correctly, but nothing to do.

We conect to MOS corretly, with correct user sign in then connectivity run by ocdoctor confirm conectivity is done:

Ops Center Doctor 4.68 [OC 12.3.3.1801,SunOS 11.3.27.4] 

======================== Checking Network Connectivity ============================== 

Using environment variable http_proxy=http://proxy-apps.seg-social.es:8080 

Please enter the My Oracle Support (MOS) Username: [email protected] 

Password: 

OS is Solaris 11, do you want to test connectivity to Oracle's S11 Support repository (Y/n): y 

To access the Solaris 11 Support Repository, files with certificate and key are required and you need to 

provide the pathes to them further down. 

prereq/check_connectivity.sh: line 164: [: : integer expression expected 

Please, use the following site to generate and download new certificate and key files: 

https://pkg-register.oracle.com/register/certificate 

After successfull download, copy the files to the Enterprise Controller. 

Enter path to S11 Certificate: /var/tmp/pkg.oracle.com.certificate.pem 

Enter path to S11 Key: /var/tmp/pkg.oracle.com.key.pem 

Test 1/5: Checking CC service reachability (without using user/password yet) 

============================================================================== 

Connecting to https://hs-ws1.oracle.com/ochi/servicecheck?type=cc 

OK: CC status is OK 

Test 2/5: Checking GUUS service (KnowledgeBase Service) reachability (without using user/password yet) 

============================================================================== 

Connecting to https://hs-ws1.oracle.com/ochi/servicecheck?type=guus 

OK: GUUS status is OK 

Test 3/5: Downloading Knowledge Channels file from updates.oracle.com 

=========================================================================== 

Connecting to https://updates.oracle.com/channels3/channels.xml 

OK: Knowledge download was successful! 

Test 4/5: Downloading patch 108437-06 from updates.oracle.com 

=========================================================================== 

Connecting to https://updates.oracle.com/all_unsigned/108437-06.zip 

OK: Patch download was successful! 

Test 5/5: Check Connectivity to S11 Support repository 

=========================================================================== 

Expire date of certificate: notAfter=Mar 21 17:10:31 2020 GMT 

Downloading S11 packages from https://pkg.oracle.com/solaris/support 

OK: Download of package [email protected] from S11 Support Repository was successful!

So user login and password are corretly setup, then our proxy too.

the other library is full we mean Oracle Solaris 11 Software Update Library.

We open a SR 3-17295073431 

Thanks in advance if someone could help us.

User_W0UJD

Comments

  • User12616849-Oracle
    User12616849-Oracle Member Posts: 7
    edited Apr 26, 2018 10:10AM

    Hi,

    Have you discovered any Sol 8-10, or Linux assets ?.    The UCE services for the library in question will make the appropriate patches available in the library after the channel (Sol 8 sparc,  or Sol 10 x86, or OEL Linux) assets have been discovered.      Prior to any of those assets being discovered by this new Ops Center EC/PC instance the library and channels are null.       The frame work for the library exists but the contents are not available as there is no specific asset type to present available patches.

    You can switch to the Disconnected mode an physically populate the library via the Harvester script discussed in the URL link below.  Though you still need to have an asset type that is served by this library to display the contents in the EC's BUI.

    Enterprise Manager Ops Center Use Disconnected Mode

    https://docs.oracle.com/cd/E59957_01/doc.123/e59993/toc.htm#OPCHL111

    I hope this helps

    User_W0UJD
  • KarthikK-Oracle
    KarthikK-Oracle Member Posts: 15 Employee
    edited Apr 26, 2018 1:41PM

    Hi,

    Please make sure that you discover the solaris 8,9 or 10 asset first.  It will start to download the channel, after discovering the asset.

    Hope this helps.

    Thanks.

    User_W0UJD
  • User_W0UJD
    User_W0UJD Member Posts: 4 Blue Ribbon
    edited Apr 27, 2018 6:03AM

    Ok thank you for your answer we will probably switch to disconected mode and try script you recomended, because we have already discovered a Solaris 10 asset, as well it has been recomended by support engineer in our SR, but library still empty.

    Aditionaly we discover a Linux asset, but library still empty.

  • User_W0UJD
    User_W0UJD Member Posts: 4 Blue Ribbon
    edited May 8, 2018 6:38AM

    Hello, we tried everything you recommended, without success, we discovered solaris 10 asset, linux asset, but nothing appears in library, then we tried disconected mode, with Harvester script, but this is unsuccesful.

    When we run the script this is how it finished:

    [email protected]:/var/tmp/harvester/harvester_bundle# ./harvester.sh --user [email protected] --password-file /root/myoraclesupport.passwd --kb-only

    Ops Center Harvester version 2.16 (May 17 2016 [Build 90]) (SunOS)

    Download log file is located in /var/tmp/harvester-wget.log

    Checking for connectivity...

    ERROR: Unable to connect to updates.oracle.com. Please check config.ini and the file /var/tmp/harvester-wget.log

           Output of the download command is:

    [Harvester version file] ERROR - Could not download. Command used:

    ./download.sh "Harvester version file" updates.oracle.com/OCDoctor/harvester-latest.version ./ "" signatures_file_not_defined

    then we check log and thisi is what appears:

    --2018-05-04 12:36:03--  https://giss.sis-abiertos-unix.giss%40seg-social.es:*password*@updates.oracle.com/OCDoctor/harvester-latest.version*password*@updates.oracle.com/OCDoctor/harvester-latest.version

    Resolving www-proxy.us.oracle.com... failed: node name or service name not known.

    wget: unable to resolve host address âwww-proxy.us.oracle.comâ

    Error downloading updates.oracle.com/OCDoctor/harvester-latest.version (return code 4), retrying...

    ERROR: Final Error downloading updates.oracle.com/OCDoctor/harvester-latest.version, could not download

    we have alredy configured proxy and ocdoctor --check-connectivity works fine, so we don't understand why www-proxy.us.oracle.com couldn't be resolved.

    Any idea?

  • KarthikK-Oracle
    KarthikK-Oracle Member Posts: 15 Employee
    edited May 8, 2018 11:49AM

    Hi,

    It cannot connect to updates.oracle.com.

    Please check the firewall rules.

    thanks,

    Karthik

    User_W0UJD
  • User_W0UJD
    User_W0UJD Member Posts: 4 Blue Ribbon
    edited May 9, 2018 5:14AM

    Hello,

    Firewalll ports are open. we try to http or https updates.oracle.com no matter the hour, answer from this website is always the same.

    Network Error (tcp_error)

    A communication error occurred: "Operation timed out"
    The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time.


    For assistance, contact your network support team.

    Your request was categorized by Blue Coat Web Filter as 'Technology/Internet'.
    If you wish to question or dispute this result, please click here.

    Issue doesn't come from our proxy, it seems updates.oracle.com is down

This discussion has been closed.