Forum Stats

  • 3,769,803 Users
  • 2,253,023 Discussions
  • 7,875,210 Comments

Discussions

Not able to perform Data Associations in Implementations of Service Task under JDeveloper BPM

User_BHELO
User_BHELO Member Posts: 12 Red Ribbon

Hi All,

Recently i got a request to enhance a BPM project done by previous Developer few months ago. After i imported the project from source code repository,i started making changes to BPMN file.

After adding the Service Task Activity, i tried to implement by making Data association.

As i drag the Variable from left panel, crossing over "Drag Objects here" in the middle section, to right panel variable, with green line moved around, it still does not get attached and turned into blue line.

Can you please help me why i am not able to Data Associate?

Even in the same bpmn file, already existing service tasks created by previous developer, the existing data associations are visible, If i delete(just for testing) one of the data association and tried to re-wire, i still not able to associate.

I compared the BPMN version in the file mentioned in first line "<bpmn:definitions fileRevision="20120601" version="12.1.3.0.0.00.00" ... " against the JDeveloper version which is "12.1.3.0.0.00.00.02.10".

The versions are almost same. Don't know where the problem is. Please help.

Answers

  • Dan Atwood
    Dan Atwood Member Posts: 2,313
    edited May 2, 2018 3:18PM

    Thanks for including the screenshot.

    Guessing you probably have this figured out by now, but you're trying to map the string (currentReviewLoginId) on the left to an object (approverAddressBookNumber) on the right. 

    Hope this helps,

    Dan

  • User_BHELO
    User_BHELO Member Posts: 12 Red Ribbon
    edited May 2, 2018 11:14PM

    The Sceenshot shows that even after i drag from left side variable towards right side variable, the green highlighter does not get converted to blue line(even after moving all around the right side variable) and map it.

    By right,  i should see small Square shaped Flash to release my mouse button after moving over to right side variable, so that data variables get wired. It is not happening.

    There could be an issue with JDeveloper and BPMN version used by previous developer and the Jdeveloper and BPMN version i am using.

    Can you help me to verify and synch up the version difference?

    If that is not an issue, what else could be the reason?

  • User_BHELO
    User_BHELO Member Posts: 12 Red Ribbon
    edited May 2, 2018 11:16PM

    I tried mapping same Data type(for that any of the variable) variable from left to right. It still does not work.

  • Dan Atwood
    Dan Atwood Member Posts: 2,313
    edited May 3, 2018 9:27AM

    Not completely sure I understand you.  For example, have you tried mapping a string to a string?  Have you tried doing this same thing in a new project to see if you get the same result?

    What JDK are you using?  Quirky things like this have occurred in the past when the wrong JDK is being used.  Because I believe you are on 12.1.3, could you verify that you are on JDK 1.7.0_51+.  The certifications for the different versions of JDKs is here:  http://www.oracle.com/technetwork/middleware/ias/downloads/fusion-certification-100350.html

  • User_BHELO
    User_BHELO Member Posts: 12 Red Ribbon
    edited May 3, 2018 1:09PM

    Thanks Dan for the reply. Yes, I tried mapping a string to string. It does not work for the existing project.

    However in a new project it works. So, it is something to do with BPMN file created using a different version of JDeveloper or BPM studio than the one I am using  to modify. This is just my assumption.

    Wth regards to JDK version, please find the screenshot of version installed. It is above 1.7.0_55.

    pastedImage_0.png

  • User_BHELO
    User_BHELO Member Posts: 12 Red Ribbon
    edited May 4, 2018 3:08AM

    Another important observation within the existing(Not new) BPM project is when if I delete existing one of the data mapping link and tried to re-join (or Data Associate by dragging from same left variable to same right variable) , IT STILL DOES NOT WORK.

    Can any of you please help me urgently?

  • Dan Atwood
    Dan Atwood Member Posts: 2,313
    edited May 4, 2018 6:57AM

    Open a console in Windows and execute “jdev.exe -verbose” or “jdev64.exe -verbose“.  The stdout might prove useful.

    I would not recommend it because there is something seriously wrong going on, but you could try using the XSLT option for the mapping.

    Probably not the cause, and only mentioning this because your screenshot shows both 1.7 and 1.8.  Double check the JVM that JDeveloper’s actually using by going to Help -> About and then look at the Properties tab to make sure JDeveloper’s using the 1.7 JVM on your machine.  JDeveloper 12.1.3 will work quirky very much like what you are seeing with JVM 1.8.

This discussion has been closed.