Forum Stats

  • 3,853,837 Users
  • 2,264,281 Discussions
  • 7,905,463 Comments

Discussions

weblogic not starting after configuring oud server to the provider of weblogic

3717022
3717022 Member Posts: 40
edited Oct 4, 2018 1:44AM in WebCenter Portal

Hi experts,

Software Updates -

WCP 12.2.1.0

OUD 11g

JAVA 1.8

I have installed and configured OUD server , created a group administrator  and assigned default user (user.0) to the following group now I have changed the flag for OUD-AUTHENTICATOR as "required" and set the flag for default authenticator  as 'sufficient' after this i have restarted my admin server but it does'nt start.

default authenticator type is ldap-authenticator.

The following errors occured are as follow:-

javax.security.auth.login.FailedLoginException: [Security:090938]Authentication failure: The specified user failed to log in. javax.security.auth.login.FailedLoginException: [Security:090302]Authentication Failed: User specified user denied.

to solve this i have  change the boot.properties to the username and password to the user who have been granted administrator role, but this didn't effected any thing.

changing the flag oud to required and default authenticator to sufficient the error occurred is give in the log below

weblogic logs are as follow..

Caused by: oracle.security.jps.JpsRuntimeException: JPS-00027: There was an internal error: You configured a generic WLS LDAPAuthenticator.

The identity store type cannot be determined. Please choose an LDAP Authentication provider that matches your LDAP server

at oracle.security.jps.wls.internal.idstore.WlsLdapIdStoreConfigProvider$WlsLdapIdStoreDescriptor.checkIdStoreType(WlsLdapIdStoreConfigProvider.java:372)

at oracle.security.jps.wls.internal.idstore.WlsLdapIdStoreConfigProvider$WlsLdapIdStoreDescriptor.getProperties(WlsLdapIdStoreConfigProvider.java:172)

at oracle.security.jps.wls.internal.idstore.WlsLdapIdStoreConfigProvider$WlsLdapIdStoreDescriptor.<init>(WlsLdapIdStoreConfigProvider.java:125)

at oracle.security.jps.wls.internal.idstore.WlsLdapIdStoreConfigProvider.getIdentityStoreConfig(WlsLdapIdStoreConfigProvider.java:85)

at oracle.security.jps.internal.idstore.ldap.LdapIdentityStoreProvider.getIdStoreConfig(LdapIdentityStoreProvider.java:175)

... 36 more

>

####<Oct 1, 2018 2:26:07 PM IST> <Notice> <WebLogicServer> <ol7.localdomain> <AdminServer> <main> <<WLS Kernel>> <> <d09036fd-fd6b-4173-8bab-a17631440f83-00000002> <1538384167467> <[severity-value: 32] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000365> <Server state changed to FAILED.>

####<Oct 1, 2018 2:26:07 PM IST> <Error> <WebLogicServer> <ol7.localdomain> <AdminServer> <main> <<WLS Kernel>> <> <d09036fd-fd6b-4173-8bab-a17631440f83-00000002> <1538384167467> <[severity-value: 8] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000383> <A critical service failed. The server will shut itself down.>

####<Oct 1, 2018 2:26:07 PM IST> <Notice> <WebLogicServer> <ol7.localdomain> <AdminServer> <main> <<WLS Kernel>> <> <d09036fd-fd6b-4173-8bab-a17631440f83-00000002> <1538384167506> <[severity-value: 32] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN.>

####<Oct 1, 2018 2:26:07 PM IST> <Info> <WebLogicServer> <ol7.localdomain> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <d09036fd-fd6b-4173-8bab-a17631440f83-00000003> <1538384167509> <[severity-value: 64] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000236> <Stopping execute threads.>

####<Oct 1, 2018 2:26:07 PM IST> <Info> <WebLogicServer> <ol7.localdomain> <AdminServer> <main> <<WLS Kernel>> <> <d09036fd-fd6b-4173-8bab-a17631440f83-00000002> <1538384167553> <[severity-value: 64] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000238> <Shutdown has completed.>

thanks

Tagged:

Answers

  • Sreedhar-Oracle
    Sreedhar-Oracle Member Posts: 476 Employee
    edited Oct 1, 2018 6:07AM

    Hi,

    Please upload config.xml for our review.

    Regards
    Sreedhar

  • Srinath Menon-Oracle
    Srinath Menon-Oracle Posts: 6,291 Employee
    edited Oct 4, 2018 1:44AM
    I have installed and configured OUD server , created a group administrator  and assigned default user (user.0) to the following group now I have changed the flag for OUD-AUTHENTICATOR as "required" and set the flag for default authenticator  as 'sufficient'

    The reason is that OUD authenticator is set to REQUIRED . This should be set to SUFFICIENT ,

    All external identity providers and Default Authenticator should be set to sufficient so that weblogic user can do the start up operations and the users from external providers are available for the applications to use .

    Change the flag for oudauthenticator to sufficient and update .

    Stop WCP server and Admin server .

    Start admin server and once it is up and running , then start WCP managed server , it will work fine .