Forum Stats

  • 3,817,447 Users
  • 2,259,334 Discussions
  • 7,893,776 Comments

Discussions

EPMA Data synchronizer & Web tier services not starting

Aarie
Aarie Member Posts: 32 Red Ribbon
edited Mar 11, 2019 7:43AM in EPM System Infrastructure

Hi Team,

When we try to start EPMA Data synchronizer and EPMA Web tier services from Windows service panel, both are throwing following error:

"The Oracle Hyperion EPMA Data Synchronizer/EPMA Web Tier service on Local Computer started and then stopped.Some services stop automatically if they are not in use by other services or programs"

When we checked the Windows event viewer, following error message is recorded for both services:

"Could not find the service start class : [Weblogic/Server]"

pastedImage_0.png

When we checked the service syserr.log, following error is recorded for both the services:

pastedImage_6.png

Good thing is that both of these services are starting successfully from backend using WebLogic managed servers start command --startManagedWebLogic.cmd EpmaDataSync/EPMAWebReports

But we have to make it work from Service panel as normal. We have already tried options like 'EPMA deployment to application server' etc but no luck.

NOTE: EPMA Server service has no issue starting from service panel.

Can you please help us troubleshoot this issue? Thanks in advance!

Tagged:

Best Answer

  • JohnGoodwin
    JohnGoodwin Member Posts: 30,471 Blue Diamond
    edited Mar 8, 2019 3:23AM Answer ✓

    The error means that the Java classes cannot be found from the classpath, these are set in the registry under

    HKEY_LOCAL_MACHINE\SOFTWARE\Hyperion Solutions\EpmaDataSync0\HyS9EPMADataSynchronizer_<instance_name>

    There will be a JVMoption (the number can differ) for classpath, for example

    pastedImage_0.png

    If I remove the classpath, the following error is generated

    pastedImage_0.png

    Cheers

    John

    Aarie
«1

Answers

  • Madhusudhan. M
    Madhusudhan. M Business Analyst Member Posts: 1,904 Silver Trophy
    edited Mar 7, 2019 9:54PM

    any errors in Event viewer ??

    Thanks,

    Mady

  • Madhusudhan. M
    Madhusudhan. M Business Analyst Member Posts: 1,904 Silver Trophy
    edited Mar 7, 2019 10:05PM

    Check out service properties whether you have correct command is there or not for starting EPMA data sync service. If it is ok, you can try one more. delete service and deploy epma once again. then check if it works or not.

    If it is running server, you can start epma from back end and continue working, to avoid disturbing setup.

    Thanks,

    Mady

    Aarie
  • Aarie
    Aarie Member Posts: 32 Red Ribbon
    edited Mar 8, 2019 12:12AM

    Hi Mady....I have attached the event viewer error screenshot in question.

  • Aarie
    Aarie Member Posts: 32 Red Ribbon
    edited Mar 8, 2019 12:56AM

    We have already tried deleting both services and then doing redeployment but still no luck. In service property 'path to executable' looks fine as given below...

    "E:\apps\OracleEPM\Middleware\user_projects\domains\EPMSystem\bin\HyS9EPMADataSynchronizer_epmsystem_web.exe" /StartClass=weblogic.Server /ServiceName=HyS9EPMADataSynchronizer_epmsystem_web /RegKey=EpmaDataSync0

    "E:\apps\OracleEPM\Middleware\user_projects\domains\EPMSystem\bin\HyS9EPMAWebTier_epmsystem_web.exe" /StartClass=weblogic.Server /ServiceName=HyS9EPMAWebTier_epmsystem_web /RegKey=EpmaWebReports0

  • Madhusudhan. M
    Madhusudhan. M Business Analyst Member Posts: 1,904 Silver Trophy
    edited Mar 8, 2019 12:32AM

    Try to execute them manually with using exe files from command prompt. Let's see what will happen...!!

    Thanks,

    Mady

  • Aarie
    Aarie Member Posts: 32 Red Ribbon
    edited Mar 8, 2019 1:00AM

    No output is coming from command prompt and surprisingly, command is getting completed within a second for both...

    pastedImage_0.png

  • Madhusudhan. M
    Madhusudhan. M Business Analyst Member Posts: 1,904 Silver Trophy
    edited Mar 8, 2019 1:22AM

    That means it is not executing command, just coming out. If you have other working environment, try the same. If all good there, copy those exe files and try to execute them here.

    compare the file size also in both environments - working and non-working.

    Thanks,

    Mady

  • Aarie
    Aarie Member Posts: 32 Red Ribbon
    edited Mar 8, 2019 2:42AM

    Surprisingly, in our other working environment too, the output of these commands are NIL within a second but from service panel both services are starting successfully. And exe file size are same in both working and non-working environments.

  • JohnGoodwin
    JohnGoodwin Member Posts: 30,471 Blue Diamond
    edited Mar 8, 2019 3:23AM Answer ✓

    The error means that the Java classes cannot be found from the classpath, these are set in the registry under

    HKEY_LOCAL_MACHINE\SOFTWARE\Hyperion Solutions\EpmaDataSync0\HyS9EPMADataSynchronizer_<instance_name>

    There will be a JVMoption (the number can differ) for classpath, for example

    pastedImage_0.png

    If I remove the classpath, the following error is generated

    pastedImage_0.png

    Cheers

    John

    Aarie
  • Madhusudhan. M
    Madhusudhan. M Business Analyst Member Posts: 1,904 Silver Trophy
    edited Mar 8, 2019 3:58AM

    Compare Registry which you are using in command prompt as john suggested.

    Thanks,

    Mady

    Aarie