OC 12.4 will not load after upgrade to S11.4, clues ? — oracle-tech

    Forum Stats

  • 3,715,959 Users
  • 2,242,917 Discussions
  • 7,845,703 Comments

Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

OC 12.4 will not load after upgrade to S11.4, clues ?

YTC-1
YTC-1 Member Posts: 4

I have/had OC12.3.3 +JIDR1 running with S11.3 SRU35

I upgraded to OC12.4, everything worked fine.

I updated the OS to S11.4 SRU8, and OC fails to start.

On the console I get

---8<

May  2 13:20:55 ytc-emoc sshd[40845]: error: PAM: No account present for user for illegal user ajaxterm from 127.0.0.1

May  2 13:24:36 ytc-emoc login: ROOT LOGIN /dev/kz/term/2

May  2 13:26:28 ytc-emoc cacao_launcher:scn-proxy[48260]: Common agent container launcher : Common Agent Container exited abnormaly

May  2 13:26:28 ytc-emoc cacao_launcher:scn-proxy[48260]: Common agent container launcher : no retries available

---8<

Relevant SMF

---8<

online     11:59:45 svc:/application/odoc-import:default
online     12:03:23 svc:/application/man-index:default
online     13:20:49 svc:/application/scn/oralistener:default
online     13:20:49 svc:/application/scn/satellite-enable:default
online     13:20:54 svc:/application/scn/ajaxterm:default
online     13:21:34 svc:/application/scn/db:default
online     13:21:34 svc:/application/scn/db:local
online     13:21:34 svc:/application/scn/oracle:default
online     13:28:26 svc:/application/pkg/server:default
online     13:28:29 svc:/application/pkg/depot:default
online     13:28:48 svc:/application/scn/uce-scheduler:default
online     13:28:48 svc:/application/scn/uce-server:default
offline    11:54:35 svc:/application/scn/proxy-available:default
offline    11:54:36 svc:/application/scn/satellite-available:default
offline*   13:28:42 svc:/application/management/common-agent-container-1:scn-proxy
offline*   13:28:56 svc:/application/management/common-agent-container-1:oem-ec

uninitialized  11:54:31 svc:/application/graphical-login/gdm:default

uninitialized  11:54:51 svc:/system/ocm:default

---8<

The OEM-EC log

---8<

tail -f /var/svc/log/application-management-common-agent-container-1:oem-ec.log

[ 2019 May  2 13:26:24 Executing stop method ("/usr/lib/cacao/lib/tools/scripts/cacao_smf stop oem-ec"). ]

[ 2019 May  2 13:26:33 Method "stop" exited with status 0. ]

[ 2019 May  2 13:26:33 Enabled. ]

[ 2019 May  2 13:26:33 Executing start method ("/usr/lib/cacao/lib/tools/scripts/cacao_smf start oem-ec"). ]

[ 2019 May  2 13:28:49 Method "start" exited with status 0. ]

[ 2019 May  2 13:28:49 Stopping because service disabled. ]

[ 2019 May  2 13:28:49 Executing stop method ("/usr/lib/cacao/lib/tools/scripts/cacao_smf stop oem-ec"). ]

[ 2019 May  2 13:28:56 Method "stop" exited with status 0. ]

[ 2019 May  2 13:28:56 Enabled. ]

[ 2019 May  2 13:28:56 Executing start method ("/usr/lib/cacao/lib/tools/scripts/cacao_smf start oem-ec").

---8<

Which log(s) do I need to look at next  ?

Best Answer

  • YTC-1
    YTC-1 Member Posts: 4
    edited May 2019 Accepted Answer

    Sorted it.

    SRU8 (or earlier) appears to revert cacao version to 2.4.4

    I noticed that SRU4 had 2.4.7

    I redid the upgrade against that and it worked.

    No SR raised, I'll let someone take note that there is an issue with cacao versions in the SRUs

Answers

  • KarthikK-Oracle
    KarthikK-Oracle Member Posts: 15 Employee
    edited May 2019

    Hi,

    I see offline* on the oem-ec cacao service.

    Please look at the /var/cacao/instances/oem-ec/logs/cacao.0 log for further details.

    It might give a clue. If you still have issues, please open a SR.

    thanks,

    Karthik

  • YTC-1
    YTC-1 Member Posts: 4
    edited May 2019

    I looked, it didn't give any further clues, to the uninitiated in the ways of cacao logs :-)

    I'll try and decipher the log some more in the meantime, but info seems to be few and far between.

  • KarthikK-Oracle
    KarthikK-Oracle Member Posts: 15 Employee
    edited May 2019

    Please open a new SR with Oracle support.

    thanks,

    Karthik

  • YTC-1
    YTC-1 Member Posts: 4
    edited May 2019 Accepted Answer

    Sorted it.

    SRU8 (or earlier) appears to revert cacao version to 2.4.4

    I noticed that SRU4 had 2.4.7

    I redid the upgrade against that and it worked.

    No SR raised, I'll let someone take note that there is an issue with cacao versions in the SRUs

Sign In or Register to comment.