Forum Stats

  • 3,814,351 Users
  • 2,258,865 Discussions
  • 7,892,678 Comments

Discussions

No Module Name Json Error

3911660
3911660 Member Posts: 3
edited Sep 16, 2019 6:30AM in Planning and Budgeting

Hello Experts,

I am trying to connect my PBCS instance with ODI 12.2.1.6 by using EPM Cloud Services as Topology.

My motto is to load the data in PBCS Instance by using ODI as integration tool but during this i am getting the error like " No Module name Json"  with ODI:-1590  Error code.

I have also installed the Json.jar files and set this in Environment and System Variable but still i am getting the same error.

I have another requirements regarding the Rest API to connect those with ODI but as i know most of Rest API need Json modules.

All this process i am doing in my Local machine.

Please help me to find the solution for this because i have multiple work pending due to this issue.

Regards,

Dhaval.

Tagged:

Answers

  • 3911660
    3911660 Member Posts: 3
    edited Aug 14, 2019 7:33AM

    Error code for this issue:-

    ODI-1590: The execution of the script failed.

    Caused By: org.apache.bsf.BSFException: exception from Jython:

    Traceback (most recent call last):

      File "<string>", line 2, in <module>

    ImportError: No module named json

    at org.apache.bsf.engines.jython.JythonEngine.exec(JythonEngine.java:146)

    at com.sunopsis.dwg.codeinterpretor.SnpScriptingInterpretor.execInBSFEngine(SnpScriptingInterpretor.java:396)

    at com.sunopsis.dwg.codeinterpretor.SnpScriptingInterpretor.exec(SnpScriptingInterpretor.java:247)

    at oracle.odi.runtime.agent.execution.interpreter.SessionTaskScriptingInterpretor.scripting(SessionTaskScriptingInterpretor.java:190)

    at oracle.odi.runtime.agent.execution.SessionTask.scripting(SessionTask.java:105)

    at oracle.odi.runtime.agent.execution.cmd.ScriptingExecutor.execute(ScriptingExecutor.java:49)

    at oracle.odi.runtime.agent.execution.cmd.ScriptingExecutor.execute(ScriptingExecutor.java:21)

    at oracle.odi.runtime.agent.execution.TaskExecutionHandler.handleTask(TaskExecutionHandler.java:52)

    at oracle.odi.runtime.agent.execution.SessionTask.processTask(SessionTask.java:206)

    at oracle.odi.runtime.agent.execution.SessionTask.doExecuteTask(SessionTask.java:117)

    at oracle.odi.runtime.agent.execution.AbstractSessionTask.execute(AbstractSessionTask.java:886)

    at oracle.odi.runtime.agent.execution.SessionExecutor$SerialTrain.runTasks(SessionExecutor.java:2225)

    at oracle.odi.runtime.agent.execution.SessionExecutor.executeSession(SessionExecutor.java:610)

    at oracle.odi.runtime.agent.processor.TaskExecutorAgentRequestProcessor$1.doAction(TaskExecutorAgentRequestProcessor.java:718)

    at oracle.odi.runtime.agent.processor.TaskExecutorAgentRequestProcessor$1.doAction(TaskExecutorAgentRequestProcessor.java:611)

    at oracle.odi.core.persistence.dwgobject.DwgObjectTemplate.execute(DwgObjectTemplate.java:203)

    at oracle.odi.runtime.agent.processor.TaskExecutorAgentRequestProcessor.doProcessStartAgentTask(TaskExecutorAgentRequestProcessor.java:800)

    at oracle.odi.runtime.agent.processor.impl.StartSessRequestProcessor.access$1400(StartSessRequestProcessor.java:74)

    at oracle.odi.runtime.agent.processor.impl.StartSessRequestProcessor$StartSessTask.doExecute(StartSessRequestProcessor.java:702)

    at oracle.odi.runtime.agent.processor.task.AgentTask.execute(AgentTask.java:180)

    at oracle.odi.runtime.agent.support.DefaultAgentTaskExecutor$2.run(DefaultAgentTaskExecutor.java:108)

    at java.lang.Thread.run(Thread.java:745)

    Caused by: Traceback (most recent call last):

      File "<string>", line 2, in <module>

    ImportError: No module named json

    at org.python.core.Py.ImportError(Py.java:264)

    at org.python.core.imp.import_logic(imp.java:707)

    at org.python.core.imp.import_name(imp.java:761)

    at org.python.core.imp.importName(imp.java:806)

    at org.python.core.ImportFunction.__call__(__builtin__.java:1232)

    at org.python.core.PyObject.__call__(PyObject.java:367)

    at org.python.core.__builtin__.__import__(__builtin__.java:1202)

    at org.python.core.__builtin__.__import__(__builtin__.java:1185)

    at org.python.core.imp.importOneAs(imp.java:827)

    at org.python.pycode._pyx0.f$0(<string>:138)

    at org.python.pycode._pyx0.call_function(<string>)

    at org.python.core.PyTableCode.call(PyTableCode.java:165)

    at org.python.core.PyCode.call(PyCode.java:18)

    at org.python.core.Py.runCode(Py.java:1204)

    at org.python.core.Py.exec(Py.java:1248)

    at org.python.util.PythonInterpreter.exec(PythonInterpreter.java:172)

    at org.apache.bsf.engines.jython.JythonEngine.exec(JythonEngine.java:144)

    ... 21 more

  • 3425776
    3425776 Member Posts: 1
    edited Sep 16, 2019 6:30AM

    I got the same issue.

    I did the following .

    I have downloaded the Json.jar here and put it in ODI_HOME/odi/sdk/lib.

    Restart

  • User_Z2M9P
    User_Z2M9P Member Posts: 1 Green Ribbon

    Hello All,

    I am having this exact same issue. I have tried dowloading json.jar, copying it into ODI_HOME/odi/sdk/lib but the issue persists. Has anyone been able to resolve this?