Forum Stats

  • 3,872,495 Users
  • 2,266,433 Discussions
  • 7,911,227 Comments

Discussions

Unable to connect OEM AdminServer using WLST

C. Garg-Oracle
C. Garg-Oracle Member Posts: 12 Employee
edited Oct 10, 2019 2:06PM in Enterprise Manager

Hello,

I have installed OEM on weblogic12c, now i need to update AuthenticationProvider (username/password) using WLST but i am unable to connect my weblogic ADMINSERVER using WLST.

In configuration, "Tunnling" is not enabled.

If somebody provides a pointer to rectify same.

Thanks

CM

Mukhtar Ahmad

Answers

  • JVG Sudhakar - Oracle-Oracle
    JVG Sudhakar - Oracle-Oracle Member Posts: 5 Employee
    edited Sep 18, 2019 9:50AM

    Please confirm the following details.

    1 what is the error that you are receiving.

    2 If you installed 13c EM then it has 12.1.3 weblogic shipped along with em install.

    3 Is this target weblogic server or EM-Wls server?

    if it is EM wls server, are you able to access wls console with out issues.

    Thanks,

    Sudhakar

  • C. Garg-Oracle
    C. Garg-Oracle Member Posts: 12 Employee
    edited Sep 19, 2019 2:25AM

    1 what is the error that you are receiving.

    unreachable; nested exception is:

            java.net.ConnectException: Connection refused; No available router to destination

    Use dumpStack() to view the full stacktrace :

    javax.naming.CommunicationException: [Login failed for an unknown reason: P] [Root exception is weblogic.socket.UnrecoverableConnectException: [Login failed for an unknown reason: P]]

    2 If you installed 13c EM then it has 12.1.3 weblogic shipped along with em install.

    Yes, i have 13cEM which is having 12.1.3 weblogic

    3 Is this target weblogic server or EM-Wls server?

    if it is EM wls server, are you able to access wls console with out issues.

    Yes, i am able to access WLS console without any issue.

    pastedImage_1.png

  • JVG Sudhakar - Oracle-Oracle
    JVG Sudhakar - Oracle-Oracle Member Posts: 5 Employee
    edited Sep 19, 2019 9:41AM

    We need set the domain env prior to invoke the wlst as follows.

    in 13c EM by default GCDomain will be used incase if you have not done customization.

    cd <gc_inst>\user_projects\domains\GCDomain\bin

    . ./setDomainEnv.sh

    Note: here we should use . space .slash i.e[. ./]

    Then launch the wlst and proceed further.

    Thanks,

    Sudhakar

    Mukhtar Ahmad
  • C. Garg-Oracle
    C. Garg-Oracle Member Posts: 12 Employee
    edited Sep 19, 2019 11:37AM

    I tried that way but same issue.

    Could you let me know on which port i need to connect admin server in WLST and protocol should be t3?

    Mukhtar Ahmad
  • Guru Prasad-Oracle
    Guru Prasad-Oracle Member Posts: 25 Employee
    edited Sep 27, 2019 2:05PM

    Hi


    The protocol should be t3s and the port should be AS_HTTPS_PORT value that is set in  "emgc.properties" file.

    Default port is 7101.

    Location of emgc.properties file ../gc_inst/em/EMGC_OMS1/

    Regards,

    Guru

  • C. Garg-Oracle
    C. Garg-Oracle Member Posts: 12 Employee
    edited Oct 10, 2019 2:37AM

    Getting below error -

    <Oct 10, 2019 6:32:43 AM GMT> <Info> <Security> <BEA-090905> <Disabling the CryptoJ JCE Provider self-integrity check for better startup performance. To enable this check, specify -Dweblogic.security.allowCryptoJDefaultJCEVerification=true.>

    <Oct 10, 2019 6:32:43 AM GMT> <Info> <Security> <BEA-090906> <Changing the default Random Number Generator in RSA CryptoJ from ECDRBG128 to FIPS186PRNG. To disable this change, specify -Dweblogic.security.allowCryptoJDefaultPRNG=true.>

    <Oct 10, 2019 6:32:43 AM GMT> <Info> <Security> <BEA-090908> <Using the default WebLogic SSL Hostname Verifier implementation.>

    Traceback (innermost last):

      File "<console>", line 1, in ?

      File "<iostream>", line 19, in connect

      File "<iostream>", line 552, in raiseWLSTException

    WLSTException: Error occurred while performing connect : Cannot connect via t3s or https. If using demo certs, verify that the -Dweblogic.security.TrustKeyStore=DemoTrust system property is set. : t3s://xx.xx.xx.xx:7102: Destination xx.xx.xx.xx, 7102 unreachable; nested exception is:

            javax.net.ssl.SSLHandshakeException: General SSLEngine problem; No available router to destination

    Use dumpStack() to view the full stacktrace :

  • Mukhtar Ahmad
    Mukhtar Ahmad Member Posts: 16 Blue Ribbon
    edited Oct 10, 2019 2:06PM

    Looks to be port or SSL issue , please try with t3 protocol and also see if the port used in this is the correct one.