Forum Stats

  • 3,769,363 Users
  • 2,252,957 Discussions
  • 7,875,005 Comments

Discussions

Hyperion Essbase application Index cache current value setting to default value '1MB' after unloadin

3877802
3877802 Member Posts: 5
edited Oct 18, 2019 11:58AM in Planning and Budgeting

Hi Guys,

We are having planning application with one plan type. Currently application holding nearly 70 GB of data (35 .pagfiles) and 2 index files. We are using Bufferd I\O

We have a batch process scheduled to run on every afternoon and batch will below mentioned things.

1. login with maxl.

2. Unload database.

3. load database.

4. get data base properties. (display database "Application"."database";)

5. perl script to check the whether 'index cache current value' more than one GB or not, If not exit the batch.

After restarting the database 'index cache current value ' resetting to 1MB and sometimes database refusing to start.

Below is the error message we see from Application log:

[Fri Sep 27 10:16:13 2019]Local/CORPPLAN///140016206591872/Info(1070173)

Requested Cache Size + Internal Adjustment = [2313512 K bytes].

[Fri Sep 27 10:16:13 2019]Local/CORPPLAN///140016206591872/Warning(1070039)

Not Enough Memory to Allocate the Index Buffer Cache. Using default

[Fri Sep 27 10:16:13 2019]Local/CORPPLAN///140016206591872/Info(1070013)

Index cache size ==> [1048576] bytes, [128] index pages.

also sometime we are receiving below error:

[2019-09-24T12:06:23.451-04:00] [CORPPLAN] [NOTIFICATION:16] [ESMDAT-15] [ESMDAT] [ecid: 1569341170326,0] [tid: 139859914348416] Not Enough Memory to Allocate the Data Buffer Cache. [adDatInitCacheParams] aborted

[2019-09-24T12:06:23.454-04:00] [CORPPLAN] [NOTIFICATION:16] [SVR-97] [SVR] [ecid: 1569341170326,0] [tid: 139859914348416] Unable to load database [CORPPLAN]

[2019-09-24T12:06:23.454-04:00] [CORPPLAN] [NOTIFICATION:16] [SVR-97] [SVR] [ecid: 1569341170326,0] [tid: 139859914348416] Unable to load database []

[2019-09-24T12:06:23.456-04:00] [CORPPLAN] [NOTIFICATION:16] [SVR-97] [SVR] [ecid: 1569341170326,0] [tid: 139859914348416] Unable to load database []

[2019-09-24T12:06:27.965-04:00] [CORPPLAN] [NOTIFICATION:16] [SVR-139] [SVR] [ecid: 1569341187416,0] [tid: 139984869169024] Essbase Server 64-bit - Release 11.1.2 (ESB11.1.2.4.025B066)

[2019-09-24T12:06:27.965-04:00] [CORPPLAN] [NOTIFICATION:16] [SVR-35] [SVR] [ecid: 1569341187416,0] [tid: 139984869169024] Starting Essbase Server - Application [CORPPLAN]

[Fri Sep 27 10:16:13 2019]Local/CORPPLAN///140016206591872/Info(1070014)

Index page size ==> [8192] bytes.

[Fri Sep 27 10:16:13 2019]Local/CORPPLAN///140016206591872/Info(1070081)

Using buffered I/O for the index and data files

Our initial analysis:

We thought our server is running out of memory , but server team said server always have 40GB free space out od 64GB RAM.

Our observations:

1. It is not happening on daily basis.

2. If we restart application instead of database 'index cache current value' setting to the value same  'index cache setting'.

Other things to notice:

1. We reset database and reload every night.

2. Our unix box will be restated once in a 15 days.

3. Hyperion service swill recycled on daily basis.

Tagged:
Aravind_L

Answers

  • Aravind_L
    Aravind_L Member Posts: 413 Blue Ribbon
    edited Oct 16, 2019 3:39PM

    This error message usually pops up when the Index cache and Data cache exceed the available memory.

    Did you try lowering the data and index cache based on the block and page file size of the cube ?

  • 3877802
    3877802 Member Posts: 5
    edited Oct 16, 2019 3:45PM

    Hi 2819644m

    We are using Buffered I\O so we are concerned about data file cache.

    We set the index cache value based on the size of the index files.

  • 3877802
    3877802 Member Posts: 5
    edited Oct 18, 2019 11:58AM

    Hi All,

    Oracle suggested us to place below mentioned setting in .cfg file for essbase.

    _BYPASSMEMCHECKATDBINIT TRUE

    I have updated this setting and tested and i didn't see the issue with index current cache value.

    I am not able to find any information about this setting in oracle docs, Please let me know if you guys know more about this setting.

    Aravind_L