Forum Stats

  • 3,768,996 Users
  • 2,252,894 Discussions
  • 7,874,831 Comments

Discussions

Connect to WAMP

4130885
4130885 Member Posts: 2
edited Nov 10, 2019 5:23PM in Dyn Community

OK,

I'm sure you've answered this question a million times and I apologize in advance...

I'm hosting a website on a win 10 machine using Apache (WAMP).  I can access the website by way of localhost/[website].  In the past I was able to connect to the website that I host by way of another dynamic DNS service so I'm confident that the Apache (WAMP) server is configured correctly.

I bought the dyndns pro service and registered a domain per instructions.

I downloaded, installed and configured the dyndns updater.

I checked the windows firewall and the Apache server is allowed to accept internet connections on ports 80 and 443.

The network adapter on the win 10 machine I'm using as a server is configured with a static internal IP address.

I'm using a D-Link router, DIR-842, port forwarding is configured to this static IP, port 80 and 443.  Dynamic DNS is enabled on this router and configured with the dyndns domain information.

I can't connect to my website.  Anybody have any ideas?  What did I miss?

Michael.R.Taylor-Oracle

Best Answer

  • 4130885
    4130885 Member Posts: 2
    edited Nov 10, 2019 5:22PM Accepted Answer

    OK, I figured this one out accidentally.

    The windows firewall on the server machine, the default configuration for the Apache (WAMP) server was to allow external connections with an option to allow internal network connections.  I changed the default configuration to allow internal connections and now I have internet connectivity to my website.

    I'm going to blame this one on a Horizon VH-2402S Fast Ethernet Switch which occupies a network topography position between the D-Link router and the server machine.

    That's my story and I'm sticking to it.  All it has to do is work, right?

    Michael.R.Taylor-Oracle

Answers

  • 4130885
    4130885 Member Posts: 2
    edited Nov 10, 2019 5:22PM Accepted Answer

    OK, I figured this one out accidentally.

    The windows firewall on the server machine, the default configuration for the Apache (WAMP) server was to allow external connections with an option to allow internal network connections.  I changed the default configuration to allow internal connections and now I have internet connectivity to my website.

    I'm going to blame this one on a Horizon VH-2402S Fast Ethernet Switch which occupies a network topography position between the D-Link router and the server machine.

    That's my story and I'm sticking to it.  All it has to do is work, right?

    Michael.R.Taylor-Oracle