Forum Stats

  • 3,852,474 Users
  • 2,264,108 Discussions
  • 7,905,077 Comments

Discussions

Oracle WebCenter Portal - Login

jahanbakhsh
jahanbakhsh Member Posts: 13
edited Feb 3, 2020 8:27AM in WebCenter Portal

Hi everybody,

    I've install Oracle WebCenter on Oracle Linux 7 (WebCenter Content, Portal & Site). For the WebCenter Content, everything is OK and all managed servers are started, properly. In addition, I can login and load every page on each related URLs such as http://hostname:7001/console, http://hostname:16200/cs, http://hostname:16225/wcc, http://hostname:16250/ibr; all of these URLs are access-able and there's no problem.

    With regards to the WebCenter Portal, the managed-server "WC_Portal" is in "RUNNING" mode and healthy. But when I try to access the portal via http://hostname:8888/webcenter, the login.jsp page isn't working (The full URL is: http://hostname:8888/webcenter/system/login.jsp ); the message is:

This page isn’t working

host is currently unable to handle this request.

HTTP ERROR 500

Kindly advise.

Daniele Bocciolini

Answers

  • Daniel Merchán
    Daniel Merchán Enterprise Achitect Member Posts: 2,192 Gold Trophy
    edited Jan 13, 2020 9:09AM

    Hello Jahan,

    You mentioned "Site", do you mean Oracle WebCenter Portal and Oracle WebCenter Sites have been installed in the Same WebLogic Domain?

    Kind regards.

  • jahanbakhsh
    jahanbakhsh Member Posts: 13
    edited Jan 30, 2020 12:59PM

    Hello Merchan,

         Yes, all the WebCenter package including WebCenter Content, WebCenter Portal and WebCenter Site has been installed in one domain, and exactly based on the oracle installation documents & recommendations.

    Best regards,

    Jahanbakhsh,

    30/01/2020

  • Daniel Merchán
    Daniel Merchán Enterprise Achitect Member Posts: 2,192 Gold Trophy
    edited Jan 31, 2020 3:42AM

    Hello,

    Oracle WebCenter Portal & Content can be installed in the same WebLogic Domain. However, Oracle WebCenter Sites cannot be installed in the same domain as Oracle WebCenter Portal due to some classpath issues.

    My recommendation (instead of fixing classpath issues manually) is that you install WebCenter Portal and Sites in separate WebLogic domains.


    In addition, there is an article in MoS (My Oracle Support) where Oracle confirms that Portal and Sites must be installed in separate WebLogic Domains.

    Regards.

    Daniele Bocciolini
  • jahanbakhsh
    jahanbakhsh Member Posts: 13
    edited Feb 1, 2020 1:07PM

    Hello Daniel,

         Thank you so much for your help. As I mentioned earlier, the portal server is in "RUNNING" mode and healthy as good as the WebCenter Content servers. In addition, you mentioned that oracle WebCenter Portal & Content can be installed in the same WebLogic domain. Finally, after starting the WebCenter Portal server, it goes to the "RUNNING" status, but when I try to access the portal via http://hostname:8888/webcenter, the login.jsp page isn't working (The full URL is: http://hostname:8888/webcenter/system/login.jsp, the login page can not be loaded; the error message is:

    This page isn’t working

    host is currently unable to handle this request.

    HTTP ERROR 500

    Kindly advise is it possible to load the portal login-page truly or not. If I uninstall the WebCenter Sites, then is it possible to load the portal login page?

    Thank you again..

  • Daniel Merchán
    Daniel Merchán Enterprise Achitect Member Posts: 2,192 Gold Trophy
    edited Feb 3, 2020 8:27AM

    Hi,

    Uninstalling WebCenter Sites or having a fresh installation of Portal with Content in a separate domain will load the Login Page properly.

    Kind regards.