Forum Stats

  • 3,727,199 Users
  • 2,245,333 Discussions
  • 7,852,622 Comments

Discussions

zmq.backend.cython.socket.Socket.bind error trying to install DynUpdater

user7525195
user7525195 Member Posts: 2
edited January 2020 in Dyn Community

Hey everyone, I am having a hard time getting DynUpdater installed on my new PC.  I have been using DynUpdater (official from dyn's site) for years on my old PC without any problems to speak of.

However, this past week, I built a new PC, uninstalled DynUpdater from my old PC, and downloaded the latest version of DynUpdater from the site.  Upon attempting install, the progress bar gets to about 60% or 70% and then just hangs.  It eventually fails, but I've tried to do some troubleshooting as to why it is failing.  The service that installation is trying to create is created, but upon startup, it is throwing this error into the Event log:

The instance's SvcRun() method failed

Traceback (most recent call last):

  File "/win32serviceutil.py", line 835, in SvcRun

  File "/lib\daemon\windows.py", line 230, in SvcDoRun

  File "/lib\daemon\windows.py", line 281, in main

  File "/lib\daemon\common.py", line 158, in start_zmq

  File "zmq/backend/cython/socket.pyx", line 487, in zmq.backend.cython.socket.Socket.bind (zmq\backend\cython\socket.c:5156)

  File "zmq/backend/cython/checkrc.pxd", line 25, in zmq.backend.cython.checkrc._check_rc (zmq\backend\cython\socket.c:7535)

zmq.error.ZMQError: Address in use

%2: %3

I have tried searching Dyn's forums as well as the internet in general, but I haven't found a resolution.  I am admin on the box, so I don't believe it is a permissions issue and nothing else about the build of the PC, the setup of Windows, or the installation of any other software has given me any trouble, so I believe this problem is isolated to this one installation.

Any help you could provide would be greatly appreciated.

Answers

  • RotBlitz
    RotBlitz Member Posts: 149 Red Ribbon
    edited January 2020

    I cannot help you with installing this update client, because I'm just a user like you.  You have to raise a support ticket with Oracle/Dyn support to get a solution for this Dyn software.

    However, feel free to use a different DDNS update client for the time being, for example the built-in client on your router, or the software from https://updater.marc-hoersken.de/ until Dyn support provided a solution.

  • user7525195
    user7525195 Member Posts: 2
    edited January 2020

    Thanks for the input.  I have opened a ticket with Dyn and I am hoping to get an answer from them, but I thought I'd reach out to the community at the same time, in case someone had seen the issue before.  I would prefer to stick with the official client as I have multiple host entries I need to update and their interface works well for that.

  • RotBlitz
    RotBlitz Member Posts: 149 Red Ribbon
    edited January 2020

    Fine.  If you have multiple hostnames to update, then there is still an alternative solution.  You will be using DNS-O-Matic to propagate your updates to your hostnames and services.  Also this can be done by Marc's Updater which supports also DNS-O-Matic.  You even can get email notifications with this.  Maybe an improved solution in comparison to the "official client".

  • Michael.R.Taylor-Oracle
    Michael.R.Taylor-Oracle Posts: 255 Employee
    edited January 2020

    Hi @user7525195,

    If you can share the ticket number with me I would appreciate it so I can make certain it gets to the right teams. In the meantime, what version of the updateclient are you using? have you tried using an older version? what OS are you installing it onto?

    Mike

    Oracle + Dyn

Sign In or Register to comment.