Forum Stats

  • 3,853,841 Users
  • 2,264,285 Discussions
  • 7,905,471 Comments

Discussions

Clarification on note ID 2371875.1

Christophe Lize
Christophe Lize Member Posts: 23 Blue Ribbon
edited Mar 9, 2020 1:49PM in Enterprise Manager

Hi All,

In doc "[EM 13.2] Agent Patching From Console Fails At OPatch Upgrade Step With "Error: 011 OPatch installation failed" (Doc ID 2371875.1)", can anyone help me to understand what they mean by :

This is due to same opatch version automatically available in software library

pastedImage_4.png

What do they mean by "automatically available in software library"?

I'm in OEM 13.3 but I have the exact same error as described in the document but the workaround is not really acceptable because I want to upgrade the OPatch software within the agent software I want to patch.

I uploaded manually OPatch 13.9.3.3 into the Software Library by clicking on download to software library on my oracle support within OEM. I did that because when I was analyzing a patch plan without the OPatch Upgrade option, it was complaining about OPatch being at the wrong version 13.8 and that the latest OPatch was not in the Software Library. Even, when I ran the job "OPatch update".

Any idea?

Thanks

Christophe

Answers

  • Courtney Llamas-Oracle
    Courtney Llamas-Oracle Member Posts: 782 Employee
    edited Feb 5, 2020 9:53AM

    What patch are you trying to apply to the agent?   can you confirm the opatch version of the agent currently?  

  • Christophe Lize
    Christophe Lize Member Posts: 23 Blue Ribbon
    edited Mar 9, 2020 1:36PM

    Hi Courtney,

    Sorry for the delay... :-/

    Oracle Home       : /u00/app/oracle/product/agent13c/agent_13.3.0.0.0

    Central Inventory : /u00/app/oraInventory

       from           : /u00/app/oracle/product/agent13c/agent_13.3.0.0.0/oraInst.loc

    OPatch version    : 13.9.3.3.0

    OUI version       : 13.9.1.0.0

    I was trying to apply the latest PSU on the agent using the console. The workaround I used, was to patch OPatch manually and then patch using the console and uncheck the box to not patch OPatch at the same time.

    As I'm using Gold Images to deploy agent, I just have to do that once on my source host, so, not too bad...

    Thanks

    Christophe

  • Venkata Thiruveedhi-Oracle
    Venkata Thiruveedhi-Oracle Posts: 590 Employee
    edited Mar 9, 2020 1:49PM

    Hi Christophe,

    I suspect the issue was due to one of the old OPatch versions which had the issue is already available in software library is causing this issue.

    The workaround you have used is absolutely correct and that is one way to go past this issue.

    One more option i think off is to check and delete the opatch from the software library which is causing the problem. Then use the OPatch Upgrade option and this should take care of this issue.

    Best Regards,

    Venkat