Node4 is regised with Node 3 instances (Node4 is running +ASM3) — oracle-tech

    Forum Stats

  • 3,714,741 Users
  • 2,242,616 Discussions
  • 7,845,043 Comments

Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Node4 is regised with Node 3 instances (Node4 is running +ASM3)

AsankaG
AsankaG Member Posts: 12
edited March 2020 in Exadata

Hi All

Due to an error with New "node 3" we had to add "node 4" first to the cluster, then we added Node3 once the issue was rectified. The sequence was 1 2 4 3'

Problem now is, Node 3 is running +ASM4, and any another database that we might created on the cluster (say db4), while Node4 is running +ASM3 and anything database that we created (Say DB3).

I need to rectify this? Do I need to delete the nodes and readd them in sequeancy "1 2 3 4" or is there a way to correct this (as Node 3 - +ASM3, DB3 …….. and Node 4 - +ASM4, DB4 ………)

My environment is as below

Grid Version - 12c

Database version - 12c

Number of RAC nodes - 2 Old and 2 New (New ones are the ones that are having this issue!

OS version - OEL 7.6  - x86_64

Thank you and Kind regards

ASanka

Tagged:

Answers

  • AsankaG
    AsankaG Member Posts: 12
    edited February 2020

    Hi, it seems there is two ways to go about this, both seems bit drastic

    1. To deinstall CRS and reinstall

    2. Delete the nodes that are running wrong instance and put them back in to the cluster in right sequence

    are above the only way?

    Thank and Kind Regards

    Asanka

  • AsankaG
    AsankaG Member Posts: 12
    edited March 2020

    Hi All, hope this would be a help to some one

    To correct the ASM instance and Node where it is configured to run, one needs to first deconfigure the cluster on such nodes and then run root.sh from the GI home in the order you want the ASM instances to be numbered.

    Regards

    Asanka

Sign In or Register to comment.