Forum Stats

  • 3,851,420 Users
  • 2,263,974 Discussions
  • 7,904,701 Comments

Discussions

Effective date parameter not getting auto incremented when Scheduling HCM Extracts

User_X0FP9
User_X0FP9 Member Posts: 2 Red Ribbon
edited Apr 20, 2020 2:39PM in HCM Cloud Service

Hi ,

My requirement is to schedule a HCM Extract to run daily.

Input parameter is Effective date. This date needs to be the sysdate every day it runs.  To achieve this i did below.

1. In Refine extracts parameters , made effective date as SQL bind to have Select sysdate from dual.

This didnt work. After i scheduled, effective date is getting passed as the same date that i have created the schedule.

If i started to schedule my extract from yesterday Apr 3rd was taken as effective date. When the schedule has to run today it has to run with Apr 4th, still it runs with Apr 3rd.

2. From Oracle doc 1615954.1, i follwed steps to change instead of doing from Refine extracts Parameters tab, i edited effective date parameter from Tasks tab then Effective date

as Context bind as Sysdate.

This didnt work. After i scheduled, effective date is getting passed as the same date that i have created the schedule.

If i started to schedule my extract from yesterday Apr 3rd was taken as effective date. When the schedule has to run today it has to run with Apr 4th, still it runs with Apr 3rd.

How to achieve this. Please advise.

Thanks,

Sreenath

Answers

  • R Mark
    R Mark Member Posts: 7 Red Ribbon
    edited Apr 20, 2020 2:39PM

    In the filter of the OTBI report I change the filter to SQL and then enter in this formula after the date field you want to enter.

    This example uses yesterday.

    < TIMESTAMPADD(SQL_TSI_Day,-1,CURRENT_DATE)

    pastedImage_0.png