Forum Stats

  • 3,727,187 Users
  • 2,245,333 Discussions
  • 7,852,620 Comments

Discussions

Plugin Deployment Jobs get "Suspended on Lock" status.

Pat_Elliott
Pat_Elliott Member Posts: 17
edited April 2020 in Enterprise Manager

I am trying to deploy plugins to agents. After I deploy the plugin, the job gets a status of "Suspended on Lock". The agents are not blacked out. They are up and running. Why does the job get this status? I am getting this for both the Exadata 13.3.2 and GoldenGate 13.3.2 plugins. We just applied the latest patchsets to the OMS last weekend. What exactly is locking it? I deployed the database plugin earlier this week. Could that job be locking these ones?

Answers

  • Venkata Thiruveedhi-Oracle
    Venkata Thiruveedhi-Oracle Posts: 590 Employee
    edited April 2020

    Hi,

    Generally if there are any jobs which are running and holding the resources, there is a possibility this Plugin job is locked due to the other jobs been running on the targets of the same agent OR the Host.

    Was the plugin deployment on the console was marked as completed?

    If yes, check the status of the plugin from EM Console as well as the command line of that respective agent:

    <AGENT_HOME>/bin>./emctl listplugins agent -type all

    Check if the plugin version got updated?

    If the plugin got updated and the plugin deploy / update job just got hung in this state, we might need to get this lock released.

    I would suggest to file an SR with support, so that based on the current status, the lock release can be executed.

    Best Regards,
    Venkat

  • Pat_Elliott
    Pat_Elliott Member Posts: 17
    edited April 2020

    I figured out that all of the OMSs have to be running when I deploy plugins. In fact, I can't have any blackouts in place either which is a real pain since it triggers all kinds of events. Even notification blackouts are not working. How do I turn off notifications while I deploy my plugins?

  • Venkata Thiruveedhi-Oracle
    Venkata Thiruveedhi-Oracle Posts: 590 Employee
    edited April 2020

    Hi,

    Yes. All the OMSes in your environment should be up & running.

    For disabling the notifications find the document below:

    How To Disable All Incident Rules to Stop or Suspend Notifications During Maintenance Of OMS (Doc ID 2092061.1)

    Also you can directly go to the EM Console  Setup -->  Incident Rules page and disable the Incident Rules.

    Best Regards,

    Venkat

Sign In or Register to comment.