Forum Stats

  • 3,873,336 Users
  • 2,266,535 Discussions
  • 7,911,512 Comments

Discussions

Unable to enter password on screensaver for S11.4 active session

YTC#1 - Bruce D Porter
YTC#1 - Bruce D Porter Member Posts: 106 Red Ribbon
edited May 8, 2020 3:37PM in Secure Global Desktop

Ok, this *may* be a Solaris 11.4 issue, except I don't have the issue when using a phsical desktop.

I noticed this happenong when I upgraded to S11.4 over 12 months ago, and should have done something about it sooner ....

I have SGD 5.4 running in a zone on S11.4.

I can connect OK from various devices (MacOS, Linux, Solaris). However if the screensaver is actie in Gnome 3, then I am unable to enter the user password to unlock it.

The session appears to pressing enter for me. So, I may get one or two chars in and then it activates and tells me the PW is incorrect.

To work around this, I set the screensaver to be off in Gnome 3 on the server/zone. For security I'd obviously prefer it to be on.

When using a physical desktop, I never have this issue.

Any one any idea o anywhere to look ? As I am working on the theory that it is SGD causing the issue.

Answers

  • Jan-Oracle
    Jan-Oracle Member Posts: 122 Employee
    edited May 8, 2020 12:48PM

    What patch level of SGD 5.4 do you have? Is GDM running on the server? I noticed that GDM interferes with launching gnome via /usr/bin/gnome-session

  • YTC#1 - Bruce D Porter
    YTC#1 - Bruce D Porter Member Posts: 106 Red Ribbon
    edited May 8, 2020 2:28PM

    Yes, GDM is runnng. Does that mean I am missing something ? Doesn't that need to be running for the desktop to be active ?

    Without GDM, I get no desktop

    ---8<

    Trying application server ytc1sgd.ytc

    Starting execution protocol engine

    ErrTransportNotAvailable

    Script 8392 exited with code 21 and signal 0

    Standard error of script process:

    Third tier output log:

    Session failed: Transport not available

    Session failed: Transport not available

    ---8<

    ---8< Version info

    /opt/tarantella/bin/tarantella version

    Oracle Secure Global Desktop for Solaris 10+ (5.40.901)

    Architecture code:  i86pc

    This host:  SunOS ytc1sgd 5.11 11.4.19.3.0 i86pc i386 i86pc

    Active patches:

    Patch_54p4

    apache-2.4.35_openssl-1.0.2r_jk1.2.46_64

    tomcat-7.0.91

    JVM_1.8.0_171

    Patch_54p7

    ---8<

  • Jan-Oracle
    Jan-Oracle Member Posts: 122 Employee
    edited May 8, 2020 2:56PM

    Interesting, so how are you actually launching the Gnome desktop via SGD? Like what is the Application object definition for your gnome desktop in SGD? I tried to enable GDM on my servers earlier to reproduce your problem, but GDM doesn't run on the environments I have available.

  • YTC#1 - Bruce D Porter
    YTC#1 - Bruce D Porter Member Posts: 106 Red Ribbon
    edited May 8, 2020 3:05PM

    Hmm, had to dig, bit using the Desktop option from the login

    /usr/bin/gnome-session

    Connection method - ssh -X

    Login script - unix.exp

    Env Variables - GNOME_SHELL_SESSION_MODE=classic

    App Resumability - During The User Session

  • Jan-Oracle
    Jan-Oracle Member Posts: 122 Employee
    edited May 8, 2020 3:10PM

    That is exactly how I have configured mine as well. And it works without GDM running.

  • YTC#1 - Bruce D Porter
    YTC#1 - Bruce D Porter Member Posts: 106 Red Ribbon
    edited May 8, 2020 3:17PM

    As an extra test, I have disabled gdm (again) and rebooted the server.

    ---8<

    Trying application server ytc1sgd.ytc

    Starting execution protocol engine

    ErrTransportNotAvailable

    Script 13244 exited with code 21 and signal 0

    Standard error of script process:

    Third tier output log:

    Session failed: Transport not available

    Session failed: Transport not available

    ---8<

    Is there a CLI I can use to show all the "desktop" settings ?

  • Ttaowb-Oracle
    Ttaowb-Oracle Member Posts: 5 Employee
    edited May 8, 2020 3:34PM

    Usually

        Session failed: Transport not available

        Session failed: Transport not available

    means that ssh or telnet are failing.

    See if you can ssh or telnet to the application server from the SGD server as the user ttasys on the SGD server and as whatever user you would be using for this application on the application server.

  • YTC#1 - Bruce D Porter
    YTC#1 - Bruce D Porter Member Posts: 106 Red Ribbon
    edited May 8, 2020 3:37PM

    Ok, semi sussed.

    While secuirng my systems last week running compliance report, I disabled ssh on the sgd-server as it suggested :-) . (I totally forgot it was used by SGD)

    Presumably I was still able to connect, because GDM was running. (hence why I could not get a connection without it just now).

    Re-enabled ssh, and I can now get a desktop without gdm being enabled :-)

    Now I will have to go away and find the incantation string to get Gnome to do screensavers again (I had switched that off to stop the issue).

    With GDM active  I still had a screensaver button to activate manually.

    Cheers for the guidence that led me in the right direction, it has bugged me ever since I upgraded to S11.4 :-)