dyn_updater issues on Ubuntu 18.04 and 20.04 — oracle-tech

    Forum Stats

  • 3,700,898 Users
  • 2,239,234 Discussions
  • 7,834,909 Comments

Discussions

dyn_updater issues on Ubuntu 18.04 and 20.04

user10966949user10966949 Posts: 1
edited May 9 in Dyn Community

I have a fresh installation of Ubuntu 20.04 and am having issues with the dyn_updater. When running it, i get an ImportError on libffi.so.6. I created a symlink from libffi.so.7. That allowed the front end to run and I configured everything. But now when I try to run the front end, I just get a message "No systemtrayicon availale" and no UI appears (although I can see the daemon running). If I remove daemon.cfg, the UI starts as expected, but then I'm back in the same situation where after the initial config is done, the GUI won't run a second time.

Moving on from that, the instructions how to have the service start "with your computer" are wrong, since that causes the service to start only on login. So I am trying to have it started via systemd. If I use /usr/bin/dyn_updater as my ExecStart parameter, it exits with a message that it cannot connect to the X server. If I use /usr/bin/dyn_updater --daemon start, the daemon.log gets a message that it can't get the IP address for my hosts. The daemon form works fine directly from the command line, running as the same user.

The exact same thing occurs on a clean installation of 18.04 (except for the libffi.so.6 issue)

Any ideas?

Sign In or Register to comment.