Forum Stats

  • 3,827,580 Users
  • 2,260,795 Discussions
  • 7,897,305 Comments

Discussions

Tell us about your experience with the "Oracle Enterprise Manager App for Grafana ”

1235718

Answers

  • Mark L
    Mark L Member Posts: 11 Blue Ribbon
    edited Sep 2, 2020 3:33AM

    Yes, I know that command. And the difference, is that one OMS has three extra parameters (the Grafana parameters). Compared to the other.

    But how do you come to the conclusion the upgrade failed? We never had any indication it did. Except for this. The EM is running fine and without any problem. And the upgrade went fine without any warning.

    Otherwise, we had stopped and gave it a retry.

  • ganessub-Oracle
    ganessub-Oracle Member Posts: 38 Employee
    edited Sep 2, 2020 9:10AM

    The reason why I am saying the patch might have not been applied correctly is because of this failure:

    # emctl set property -name oracle.sysman.db.restfulapi.grafana.throttle.max.concurrent.request -value 5

    Oracle Enterprise Manager Cloud Control 13c Release 4

    Copyright (c) 1996, 2020 Oracle Corporation. All rights reserved.

    SYSMAN password:

    Definition does not exist for property "oracle.sysman.db.restfulapi.grafana.throttle.max.concurrent.request". Can not set property value

    We have introduced this property as part of RU3 patch. This property will be registered into OMR during patch installation. So if emctl errors out with, it does not know what is ""oracle.sysman.db.restfulapi.grafana.throttle.max.concurrent.request" , then I was just thinking during patch installation somehow the DBProfDefinition.xml registration did not go through fine for some reason.

    Can you look into the DBProfDefinition.xml and see whether you can find "oracle.sysman.db.restfulapi.grafana.throttle.max.concurrent.request" entry in it?

    Usual location of this file will be something like below (it could be different in your installation but just try to locate the DBPropDefinition.xml in the latest oracle.sysman.db.oms.plugin_13.x.x.x.x directory):

    /u00/app/oracle/product/em13cr2/middleware/plugins/oracle.sysman.db.oms.plugin_13.4.1.3.0/metadata/omsProperties/definition/DBPropDefinition.xml

  • User_R3V43
    User_R3V43 Member Posts: 2 Employee
    edited Sep 14, 2020 10:59AM

    Hello,

    I have a customer using Grafana 7.0.1; and would like to know when will this version be certified with EM 13.4.

    Regards,

  • Murtaza Husain-Oracle
    Murtaza Husain-Oracle Posts: 44 Employee
    edited Sep 14, 2020 12:52PM

    Greetings,

    We are planning to have it certified by mid October.

    Thanks,

    Murtaza

  • User_4HR1Z
    User_4HR1Z Member Posts: 7
    edited Sep 21, 2020 7:52AM

    Greetings from Bavaria,

    is it the same certification problem with Grafana 6.7.4 or 7.1.5, because we cannot connect to OEM with "Unauthorized" ?

    grafana.log tells us only a 401 during the POST request:

    Using 1.0.2 plugin and latest OEM 13.4 version

    t=2020-09-21T10:49:08+0200 lvl=dbug msg="Received command to update data source" logger=datasources url=https://oem.audi.vwg:7799

    t=2020-09-21T10:49:08+0200 lvl=dbug msg="Applying default URL parsing for this data source type" logger=datasource type=oracle-emcc-datasource url=https://oem.audi.vwg:7799

    t=2020-09-21T10:49:08+0200 lvl=info msg="Request Completed" logger=context userId=1 orgId=1 uname=*** method=PUT path=/api/datasources/15 status=200 remote_addr=143.164.1.11 time_ms=6 size=671 referer=https://xxx.audi.de/datasources/edit/15/

    t=2020-09-21T10:49:09+0200 lvl=info msg="Request Completed" logger=context userId=1 orgId=1 uname=*** method=GET path=/api/frontend/settings status=200 remote_addr=143.164.1.11 time_ms=2 size=37177 referer=https://xxx.audi.de/datasources/edit/15/

    t=2020-09-21T10:49:09+0200 lvl=info msg="Request Completed" logger=context userId=1 orgId=1 uname=*** method=GET path=/api/datasources/15 status=200 remote_addr=143.164.1.11 time_ms=0 size=572 referer=https://xxx.audi.de/datasources/edit/15/

    t=2020-09-21T10:49:09+0200 lvl=dbug msg="Applying default URL parsing for this data source type" logger=datasource type=oracle-emcc-datasource url=https://oem.audi.vwg:7799

    t=2020-09-21T10:49:09+0200 lvl=info msg="Request Completed" logger=context userId=1 orgId=1 uname=*** method=POST path=/api/datasources/proxy/15/em/websvcs/restful/grafana/v1/ status=401 remote_addr=143.164.1.11 time_ms=47 size=0 referer=https://xxx.audi.de/datasources/edit/15/

    t=2020-09-21T10:49:09+0200 lvl=info msg="Request Completed" logger=context userId=1 orgId=1 uname=*** method=GET path=/api/login/ping status=200 remote_addr=143.164.1.11 time_ms=0 size=9 referer=https://xxx.audi.de/datasources/edit/15/

    t=2020-09-21T10:49:09+0200 lvl=dbug msg="Applying default URL parsing for this data source type" logger=datasource type=oracle-emcc-datasource url=https://oem.audi.vwg:7799

    t=2020-09-21T10:49:09+0200 lvl=info msg="Request Completed" logger=context userId=1 orgId=1 uname=*** method=POST path=/api/datasources/proxy/15/em/websvcs/restful/grafana/v1/ status=401 remote_addr=143.164.1.11 time_ms=8 size=0 referer=https://xxx.audi.de/datasources/edit/15/

    t=2020-09-21T10:49:09+0200 lvl=dbug msg="Scheduling update" logger=alerting.scheduler ruleCount=1

    Thanks a lot,

    Stefan

  • Murtaza Husain-Oracle
    Murtaza Husain-Oracle Posts: 44 Employee
    edited Sep 21, 2020 12:32PM

    Hi Stefan, Yes that is correct; currently, with v1.0.2 Plug-in/App, the highest version of Grafana server that is certified is v6.7.2.

  • User_4HR1Z
    User_4HR1Z Member Posts: 7
    edited Sep 22, 2020 4:50AM

    ...but I hope you know 6.7.3 and 6.7.4 have important security fixes. Running a version smaller than 6.7.4 is not possible !

    Stefan

  • ganessub-Oracle
    ganessub-Oracle Member Posts: 38 Employee
    edited Sep 22, 2020 5:01AM

    Stefan,

    Can you please give more details like exactly when you are hitting this 401 error. Is it during data source configuration? Are you using the correct EM Admin user id and password in the datasource configuration page?

  • User_4HR1Z
    User_4HR1Z Member Posts: 7
    edited Sep 22, 2020 5:53AM

    Hi,

    we are using Grafana 7.1.5 and 6.7.4 both with the same error after clicking at save&test during creation or update of the datasource.

    We are using https://address_of_oem:7799

    Normal login via browser and https://address_of_oem:7799/em/ is without any problem with the user and pwd of the datasource

    The permissions in OEM were set as required in the users guide with the 3 emctl set commands

    Stefan

  • ganessub-Oracle
    ganessub-Oracle Member Posts: 38 Employee
    edited Sep 22, 2020 11:33AM

    Please try the below from any terminal and let us know whether you get a JSON response or 401.

    curl -u emusername:password  --request POST 'https://address_of_em:7799/em/websvcs/restful/grafana/v1/enablestatus' \

    --header 'Content-Type: application/json' \

    --header 'Cookie: grafana_session=tef%sddeq123t' \

    --data-raw '{}'