Forum Stats

  • 3,770,713 Users
  • 2,253,156 Discussions
  • 7,875,555 Comments

Discussions

OBIEE Agent: Authentication failed: invalid user/password

maltedietsch
maltedietsch Member Posts: 5 Green Ribbon

Hello,

I have an agent that should send a dashboard page by email. But I get the following error message:

[Util Logger] Exception occurred:

Severity:1

Type:PKN3saw9ExceptionE

File:project/ibotapi/ibotrpcproxy.cpp

Line:159

Message:Authentication failed.

Authentication Failure.

Error Codes: IHVF6OM7:OPR4ONWY:U9IM8TAC:U9IM8TAC:U9IM8TAC

Location: saw.connectionPool.getConnection, saw.rpc.server.responder, saw.rpc.server, saw.rpc.server.handleConnection, saw.rpc.server.dispatch, saw.threadpool.socketrpcserver, saw.threads

Odbc driver returned an error (SQLDriverConnectW).

State: 08004.  Code: 10018.  [NQODBC] [SQL_STATE: 08004] [nQSError: 10018] Access for the requested connection is refused.

(08004)

State: HY000.  Code: 43113.  [nQSError: 43113] Message returned from OBIS.

(HY000)

State: HY000.  Code: 43126.  [nQSError: 43126] Authentication failed: invalid user/password. (HY000)

So, he seems to use a "SYSTEM" user according to servers/obis1/log files. But I don't know if this is the Oracle SYSTEM User or some intenal Weblogic "system" user. There is some kind of credential store in Weblogic where I set the DB password for the Oracle SYSTEM user (oracle.bi.system --> system.user) but I still get the error message when starting the Agent.

So, which password(s) and users did I not configure correclty?

Any help appreciated.

Thanks

Malte

Tagged:

Answers

  • Christian Berg-0racle
    Christian Berg-0racle Everything Analytics And Data Member Posts: 9,463 Gold Crown
    edited May 26, 2020 2:43PM

    Please provide pertinent details. What exact version? What OS? How is your Agent configured? *EXACTLY*

  • maltedietsch
    maltedietsch Member Posts: 5 Green Ribbon
    edited May 27, 2020 4:07AM

    Hi,

    operating System is: Oracle Linux Server 7.5.

    The schedulerconfig.xml is as follows:

    <?xml version="1.0" encoding="UTF-8" standalone="no"?>

    <scheduler>

    <ServerInstance>

            <CLIType>3</CLIType>

            <DSN>biplatform_datasource</DSN>

            <Mail>

            <!--

            NOTE:

            Values in this element may be automatically updated from the

            biee-domain.xml file.

            -->

                <From>Enterprise Information System</From>

                <SMTP_Port>25</SMTP_Port>

                <SMTP_Server>....</SMTP_Server>

                <Sender>....</Sender>

            <Try>3</Try>

    <MaxRecipients>0</MaxRecipients>

    <UseBcc>false</UseBcc>

    <UseSSL>false</UseSSL>

    <UseStartTls>false</UseStartTls>

    <SmtpCaCertificateVerificationDepth>0</SmtpCaCertificateVerificationDepth>

    </Mail>

            <MaxExecThreads>100</MaxExecThreads>

            <MinExecThreads>1</MinExecThreads>

            <PartOfCluster>True</PartOfCluster>

            <TargetType>2</TargetType>

            <iBots>

                <Log_Dir>/u01/app/oracle/config/domains/bi/servers/obisch1/logs</Log_Dir>

            </iBots>

            <Log>

                <Level>

                    <Error>1</Error>

                    <IncidentError>1</IncidentError>

                    <Trace>32</Trace>

                    <Warning>1</Warning>

                    <Notification>16</Notification>

                </Level>

                <MaximumFileSizeKb>10240</MaximumFileSizeKb>

                <MaximumLogAgeDay>3</MaximumLogAgeDay>

            </Log>

            <DefaultScriptPath>/u01/app/oracle/config/domains/bi/config/fmwconfig/bienv/OBISCH/scripts/common</DefaultScriptPath>

            <SchedulerScriptPath>/u01/app/oracle/config/domains/bi/config/fmwconfig/bienv/OBISCH/scripts/scheduler</SchedulerScriptPath>

            <SSL>

                <UseSSL>false</UseSSL>

            </SSL>

    </ServerInstance>

    </scheduler>

    So is there anything wrong with the config?

    Oracle version is: Oracle Database 12c Enterprise Edition Release 12.2.0.1.0 - 64bit Production

    And we have configured our own Authentication Provider so that the user details are retrieved from views on our system. Maybe it interferes somehow with the email agent?

    Thanks

  • Christian Berg-0racle
    Christian Berg-0racle Everything Analytics And Data Member Posts: 9,463 Gold Crown
    edited May 27, 2020 4:57AM

    a) No OBI version specified when your question is clearly for the OBI product

    b) The question was how your Agent is configured, not your scheduler

  • maltedietsch
    maltedietsch Member Posts: 5 Green Ribbon
    edited May 27, 2020 5:45AM

    Hi,

    a) No OBI version specified when your question is clearly for the OBI product

    Oracle Business Intelligence Product Version 12.2.1.4.0 (Build BIPS-20180409020153 64-bit)

    b) The question was how your Agent is configured, not your scheduler

    General

    Normal Priority, Use Specified User's Credentials: weblogic

    Schedule

    Start on 04/24/2020 02:06:00 PM Recur daily

    Condition

    Do not use a condition (always deliver content and run actions)

    Delivery Content

    /Shared Folders/EIS/Dashboards/Number Of Transactions - Daily/Number Of Transactions - Daily

    Recipients

    <none selected>

    Destinations

    Home Page and Dashboard, Email

    Actions

    <none selected>

    I enteterd one recipient email address.

    Thanks